About Mapwel
Mapwel is mapping software for creation of your own maps and their upload into the GPS unit. Unlike other
software tools that work only with tracks and waypoints, Mapwel allows to create complete maps for GPS. Click
here to see supported GPS units.

Import of files, files merging
Mapwel supported GPS units require maps in vector format. Therefore, easiest way of how to create
map for GPS is to import files in ESRI *.shp, *.gpx or other vector format into Mapwel, merge them
together and assign proper type to all map objects. Mapwel also supports import of raster images and
their automatic and manual vectorization.

Projections and datums
Imported files in both vector and raster format (especially *.shp files) may use various projections and
geographic systems. Mapwel supports hundreds of the commonly used systems, including UTM
(Universal Transverse Mercator). Internal format of map data in Mapwel is WGS84, because this format
is also internal format of the GPS units. Although user can select various coordinate systems in GPS,
coordinates are always calculated from WGS84 format. Therefore, Mapwel converts all input data into
WGS84.

Autovectorization
If you need to get raster image into GPS with just a few mouse clicks, this is the right tool for you.
Mapwel provides Automatic "one-click" vectorization of raster images (satellite imagery or
scanned maps). Garmin units do not allow to load raster image directly into the GPS and use it as a map.
Therefore, this function automatically vectorizes raster image and creates vector file compatible with
GPS. More >>

Map Georeferencing
Mapwel provides two approaches to establish relation between raster image and map coordinate
system: 1. direct calibration, 2. separate image editing and map georeferencing. In both cases, result is
a map with Lat/Lon grid parallel to the screen edges and coordinates assigned to left, right, top and
bottom edge of the map. Click here to find out more >>

User defined styles
GPS units use basic (pre-defined) and user-defined sets of polygon patterns, line styles and symbol
icons. Mapwel provides easy-to-use editor of user styles, which are supported by most of the new
Garmin GPS. Click here to find out more >>

Manual Map Drawing
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Manual Map Drawing
Map can be drawn from the scanned paper chart, aerial photos, satellite images and/or with use of
tracks and waypoints imported from your GPS. Tracks and waypoints are automatically converted into
the map elements. Mapwel allows to draw map with use of straight lines and curves. When drawn
with curves, map can be uploaded into the GPS with chosen precision/data-size ratio. User can apply
Contrast, Brightness and Gamma filters to the scanned chart or satellite image to adjust the
background for convenient drawing of vector objects on the top. To make drawing of complex objects
easier, Mapwel provides Opening in the Area tool.

Tools
Mapwel tools help to manage maps in your GPS, which are normally not accessible, or hard to
manipulate because they are all merged into a single file. ' Add maps to other maps in GPS' function
allows to add your map to those already present in the GPS memory. 'Delete specific maps in GPS'
allows to erase individual maps from your map set. 'Merge IMG files' alllows to combines several maps
into a single file for use with Nüvi, Zümo, Colorado, Oregon or unit, which memory is directly accessible
from Windows.
Other Mapwel tools help to create map faster. For example, 'Create Circle around Point' function for
aviation maps creates 'circles' of defined radius around all selected points. Very large 'circles' look
deformed near poles, because of coordinate system projection. However, real-world distance from
center to any point on the "circle" is the same.

Freehand Tool
Unlike the other Mapwel drawing tools, which are based on the precise manual placement of the nodes,
curves and lines, Freehand tool allows to draw many of the Mapwel objects very fast with a free hand.
Strokes are automatically converted into the chosen style. After conversion, strokes can be edited as
other vector objects (node by node).

Trace Tool
This is another tool for faster vectorization of the raster image. It allows to vectorize one object (or set
of similar objects) at once, but it cannot vectorize whole map with different types of objects at once.
Tracing should be repeated for respective types of objects (filled areas, roads, rivers, etc.). Trace tool
works on images with any common color depth (including True Color and bi-tone) that are sufficiently
clean.

Object Inspector
Object Inspector box at right side of the main Mawpel window displays information about respective
map objects and simplifies the object manipulations. It also allows to select one or several objects in the
work space.

WYSIWYG
Mapwel allows to draw the map in any colors you choose and the 'What you see is what you get'
interface (WYSIWYG) shows how the map will look like on the color or monochrome GPS display.
Mapwel also simulates the Nighttime and Marine color modes. When drawing the map, use display
mode tabs in the left bottom corner of the Mapwel screen to review your map in the real GPS colors.

Properties of Objects
Each object has adjustable properties like name, comment (text that is displayed in GPS when cursor
stays on top of the object), type, max. zoom level, etc. POI (points of interest) may have address and
phone number assigned. It is also possible to define properties of the whole map, like name, copyright
text, address format, internal map ID, map draw priority and zoom levels of map layers.

Page 2 of 119

Automatic Object Splitting
GPS rendering engine requires large areas and lines to be split into smaller objects because of the data
structures limitations and speed of map rendering. Mapwel splits all objects automatically without loss of
the map detail when it uploads map into the GPS. User does not have to bother about the object size or
detail limitations. Splitting process runs internally without user even knowing about it.

Accuracy
Map scope A ccuracy
< 45°

+-2.4 m

90°

+-4.8 m

180°

+-9.6 m

Both technical and software limitation of GPS units restrict accuracy of maps (see the Accuracy table).
This restriction is related to the map scope. It means that very large map is represented in GPS with
lower accuracy than the small or normal size map. Mapwel automatically converts all map data into the
best possible accuracy level.

Map Uploading and Export
Finished map can be saved into Mapwel *.mpw file format, exported into *.img, *.kml or other
supported format, or uploaded directly into the GPS. Export of map into other than *.mpw file is
supported by Mapwel Advanced version only. Mapwel includes separate MapUpload program for loading
*.img files into the GPS. MapUpload also allows to pack several img files into a single executable file to
distribute to your friends or customers.

All in One
Creation of map for GPS involves drawing or import of map, conversion of data into GPS native format and upload
of data into GPS. Mapwel is the only available software that allows user to do above three steps with a single
software tool.








Use Mapwel WYSIWYG workspace to create complete GPS map with filled areas, all types of lines, map
features, cities, exits and points of interest with adresses. Do not limit yourself to just tracks and
waypoints. Use Mapwel import capabilities to open existing maps in various formats.
When converting to GPS native format, Mapwel automatically splits large objects to meet GPS technical
requirements and does lot of other automation to make creation of map as easy as possible.
Upload your map directly into the GPS. Mapwel allows you to add your map to other maps already present
in GPS memory. With Advanced version you can even export map into GPS native IMG file.
Other most important features include: Free map loader (for IMG files from other sources), Delete specific
maps in GPS function, UTM projected system and many geographic systems support.

Demo

Mapwel is available for download and testing in FREE demo mode. Demo is fully functional except the limit on
number of objects (map elements) that can be uploaded into the GPS. Therefore, maps uploaded into GPS with
demo are incomplete.

Levels

Registered Mapwel software is available in two levels:

1. Basic, for single GPS unit. Basic version allows user to upload map only into the GPS with ID that was
used for registration. This version is intended for personal use.
Advanced, for unlimited number of GPS units. Advanced version requires GPS (the one used for
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used for registration. This version is intended for personal use.

2. Advanced, for unlimited number of GPS units. Advanced version requires GPS (the one used for
registration) to check validity of password only once after installation of Mapwel. Then user may attach
any other compatible GPS and upload maps into it. This version is intended for personnel or organizations
that own number of GPS units. Advanced version allows to export maps into IMG, KML and MP format and
supports batch conversion mode.

Registration (Purchase)

To turn demo version into full version without limit user needs to purchase registration password and enter it
into the Mapwel. No additional download is needed. Registration password is derived from the GPS unit ID
number. This number is required for registration.
When uploading maps into GPS, Mapwel checks the ID of attached GPS. Therefore, GPS with ID used for
registration is needed for uploading maps. Mapwel Advanced (see Advanced version), checks registered GPS
only once, after installation.

Requirements



Windows 98/Me, Windows NT/2000/XP, Windows Vista compatible.
Minimum hardware requirements: 256 mega bytes RAM, screen resolution 1024x960, True Color display
mode
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Supported GPS Models
Model
Garmin™ Mobile® XT
Garmin™ Astro®
Garmin™ Oregon®(all models)
Garmin™ Colorado®(all models)
Garmin™ Nüvi® and Zümo®(all models)
Garmin™ Edge 605, 705®
Garmin™ iQue M3, M4, M5®
Garmin™ eTrex Summit HC®
Garmin™ eTrex Venture Cx, HC®
Garmin™ eTrex Legend, Legend C, Legend Cx,
Legend HCx®
Garmin™ eTrex Vista, Vista C, Vista Cx, Vista HCx®
Garmin™ Rino 120, 130, 520, 530, 520HCx, 530HCx®
Garmin™ GPS V®
Garmin™ GPSMAP 60C, 60CS, 60Cx, 60CSx®
Garmin™ GPSMAP 76, 76S, 76C, 76CS, 76Cx, 76CSx®
Garmin™ GPSMAP 176, 176C, 276C, 376C, 378, 478C®
Garmin™ GPSMAP 96, 96C, 196, 296, 396, 496®
Garmin™ Quest, Quest 2®
Garmin™ Street Pilot i2, i3, i5®
Garmin™ Street Pilot c320, c330, c340®
Garmin™ Street Pilot c530, c550, 580®
Garmin™ Street Pilot 2610, 2620, 2650, 2660®
Both serial and USB data transfer is supported.
NOTE: Mapwel is not affiliated with any manufacturers mentioned here. All brand names and product names are
trademarks of the respective manufacturers.
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Mapwel Registration
Mapwel is available in free demo version for evaluation purposes. Demo version truncates map uploaded into
GPS (unless it is Mapwel_Island.MPW test file) and it has also the multiple files upload option disabled.
To turn demo into fully-functioning program, user needs to purchase registration password and insert it into
demo main menu / Help / Registration.
Depending on the type of purchased password, Mapwel demo switches to Basic or Advanced registered mode.
If Mapwel is in Advanced version, user can disconnect the registration GPS after the password checking and
attach any compatible GPS for map upload. Basic Mapwel version allows user to upload map only to single GPS
unit.
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Sample Map

To test the map into GPS upload and to see how the finished map looks in the
Mapwel, use the Mapwel_Island.MPW file in the MAPWEL/FILES folder. You can
upload this map into GPS without truncation even if you have unregistered version
of software.
Note: map elements like areas, lines and symbols appear gradually as you zoom-in
the map in GPS. Use the Setup/Map/Detail menu in GPS to set detail level.
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Troubleshooting
How to use Mapwel with Garmin Mobile XT ?


Connect your phone to computer with USB cable. Select 'mass storage' mode. After a few seconds Mapwel
should be able to work with the phone like with any other GPS. Try to read GPS ID with use of Mapwel
main menu>GPS>Display GPS ID

Map cannot be found in GPS after upload from Mapwel (MapUpload) program


Most GPS (including Garmin Mobile XT) must be restarted after the map upload. Otherwise, map may be
not visible.

Map is not visible on the GPS screen, although it is listed in map list




Some GPS models (like Garmin Mobile XT) require to turn on 'Outline Detailed Map' option in Tools/Settings/Map. Otherwise, border
of custom map is not visible and this could make the searching for a custom map more difficult.
Another possible cause of this problem is wrong use of the 'Background Area' polygons. These objects are intended to define
irregular shape of the map. GPS displays only objects that are inside of the Background Area (if it is present in the map). Other objects
are ignored. If Background Area polygon is wrongly used as a fill of some map object, the whole map is invisible.

Some maps are not visible on the GPS screen


GPS does not display maps with identical ID. If you use your own numbering of maps (Mapwel > File > Properties > ID), each must
have a unique internal ID number. Unless you select 'User Defined' option, Mapwel assigns unique ID number to each map
automatically.

I use custom colors, symbols and fill patterns in my maps and some of them are displayed in weird
colors in the GPS


Although each map is saved with its own set of user defined colors and styles, GPS uses only one of those
sets. Therefore, all maps that are present in the GPS memory must have the same set of user defined
colors and styles. Otherwise, maps with different user defined sets are displayed with wrong styles.

My custom map completely covers the underlaying maps. Is it possible to make them show through my
map?


Yes, it is possible. Use Mapwel main menu > Edit > Preferences to turn on the 'Transparent map' option.
Then load the map into the GPS.

Map in GPS is displayed in other colors than those that are visible in Mapwel


Map in GPS native format can contain two types of objects: 1. basic, 2. user defined. Objects of basic
type have no color information stored with them. GPS displays them in its own pre-defined colors. User
defined objects have their own color and style assigned by user (Mapwel main menu > Objects > User
Defined Styles). Therefore, you have to use objects from the second category if you want GPS to display
them in your own colors. Moreover, Mapwel allows to draw map objects in the work area in any color to
make creation of map easier. These 'work' colors, however, are not transfered to GPS. To see how the
map will look like in the GPS, please use 'Color' tab at bottom part of the main Mapwel screen.

My auto-vectorized map is displayed as a large colored squares and details appear only when I zoom in
to 120 m


The most deatailed layer of auto-vectorized maps is supposed to appear at higher zoom levels as well.
Page 8 of 119

The most deatailed layer of auto-vectorized maps is supposed to appear at higher zoom levels as well.
Check 'Map Detail' setting in your GPS. It should be set to 'Most'.
Map looks good in Mapwel, but after loading to GPS the polylines and/or polygons become distorted and
look like zig-zag line


The finest coordinate grid used in native map format has approximately 2.5 m spacing. If polylines and
polygons in your map contain large number of very small elements, their coordinates are rounded (some up
and some down) when exported to GPS map format, creating a zig-zag effect. The work around is to make
elements of polylines and polygons longer.
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How to make your own map
Garmin GPS units accept only vector data. Therefore, creation of map in Mapwel involves several steps from
calibration of raster scan or satellite image to upload of vectorized map to GPS.
Raster files used in below example are mw.jpg and mw2.jpg. They can be found in MAPWEL > FILES folder.
Click on any below step to see simple example:
1. Direct image calibration

or

image editing+georeferencing

2. Background filters (colors)
3. Drawing/import of objects
4. Upload of map into GPS

Some of these steps are not necessarry if your input data are already vectorized and stored in file format
supported by Mapwel (ESRI shapefiles, GPX, MP). Please see the following table for steps needed when working
from a specific data format:

W ork ing from scan,
ae rial or sate llite
im age (raste r
im age )

W ork ing from
O ziEx plore r calibrate d
im age (raste r im age )

W ork ing from
ESR I shape file s
(ve ctor file )

W ork ing from
m ap in MP
form at (ve ctor
file )

Image
calibration
use r prom pte d
whe n im porting
shape file

Map
georeference
Background
filters

optional

optional

Drawing of
objects

optional

optional

Upload of map
into GPS

Only the most frequently used methods are shown in above table. Each of them can be combined with use of
your own tracks and waypoints imported from GPS, map files in GPX format downloaded from internet, etc.
There are several ways how to create vector objects for the map
-

Manual drawing of objects
Automatic vectorization of whole raster image
Automatic tracing of objects from raster image
Freehand drawing with mouse or tablet
Import of tracks and waypoints from GPS
Use of ESRI shapefiles
Merging of other Mapwel files or other compatible files (*.MP, *.GPX, etc.)

Options for managing maps in your GPS
- Erasing specific map in GPS
- Adding map to maps already present in GPS
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In case of problems with map uploading or displaying on GPS, please click here.
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Raster Image Calibration and
Georeferencing
Mapwel provides two approaches to establish relation between raster image and map coordinate system. In both cases, result is a
map with Lat/Lon grid parallel to the screen edges and coordinates assigned to left, right, top and bottom edge of the map.
Selection of proper approach depends on the type of the raster image:

Approach 1 (recommended)
is a direct map calibration. This calibration transforms raster image and vector data drawn on top of
the image to the Lat/Lon grid parallel to the screen edges. This method uses an affine linear
transformation and will work with maps which are rotated or skewed. The Lat/Lon grid of the image
must be linear (straight lines) to allow linear transformation to the grid parallel to screen edges. Even
images with a non-linear Lat/Lon grid can be calibrated with this tool, if the grid non-linearity is caused
by projection (like UTM, for example). In such a case, map usually contains linear Easting/Northing grid
and non-linear Lat/Lon grid. Calibrate map with use of the Easting/Northing grid and Mapwel
recalculates images so that the Lat/Lon grid becomes linear.

Approach 2
involves separate transformation of raster image into rectangular grid, and consequent map
georeferencing. If image (typically distorted scan or map with unknown projection) is curved in a way
that direct calibration cannot be used, it can be edited with tools for rotation, move, cropping, nonlinear straightening and morphing. The goal is to achieve Lat/Lon grid parallel to the screen edges
and optionaly to make raster image match the tracks and waypoints imported from GPS. Once the
image is calibrated, map can be georeferenced with use of 2 points.
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Image Editing
Mapwel provides several tools for image editing. This chapter deals with image rotation, cropping and
straightening. Editing of raster image is an alternative approach to calibration. Click here for more image
editing and calibration tools.

To rotate, straighten and crop image use following approach:
1. Use main menu > Image > Import function to place image into the work area background. Scanned photo
is usually rotated and distorted.

2. Use main menu > Image > Rotate to Horizontal function to rotate the image. Place the rotation marks on
a line that is supposed to be horizontal. Then click right mouse button and choose Rotate Image command from
the pop-up menu.
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3. Image is rotated so that marked grid line is horizontal now.

4. Use the main menu > Image > Straighten function to compensate the image deformity. The tool that
appears in the work area has two main marks (left top and bottom right corner) and 6 additional marks.
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5. Place two main marks on map corners first. Then move the rest of marks to a corresponding spots on the map
edge. The black dashed rectangle indicates how the map will be straighten. Click right mouse button and then
choose Straighten Image command from the pop-up menu.

6. Use main menu > Image > Crop function to eliminate the empty space around the map. Place the crop
marks and then click right mouse button to access the pop-up menu. Click on Crop Image item.
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7. Adjustment of image is finished.
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Map Georeferencing
This tool is supposed to be used if raster image has linear Lat/Lon grid parallel to the screen edges. You do not
need to use this tool if you have calibrated image with a direct Image Calibration tool. Click here for more
image editing and calibration tools.
Mapwel uses coordinates of map edges (left=west, right=east, top=north, bottom=south) as a reference frame
for all calculations.
If coordinates of edges are unknown (most common case), user can define coordinates of any two known spots
and Mapwel derives the edge coordinates from them. These two points must be not located on the same
horizontal or vertical line and they should be as far one from the other as possible.

Georeferencing map with 2 points:
Imagine the map with unknown edge coordinates:

1. Use main menu > File > Georeference Map function to define coordinates of two known spots (grid
intersections, in this case). Place the red marks onto the two known spots. Click right mouse button on the work
area to access a pop-up menu and then assign coordinates to each of the two spots.
Note: W he n using lat/lon coordinate s, we st and south coordinate s are re garde d as if the y we re ne gative , i.e . W 80 is -80, for
e x am ple .
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2. Use Apply to Map Coordinates command from the pop-up menu. Note that map edge coordinates are
adjusted automatically according to the two defined spots. Map edge coordinates recalculated to WGS84.

Notes
To change coordinates format, elevation units, distance units, map transparency, transfer speed and curves
precision, use the main menu Edit > Preferences.
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Background Filters (Colors)
When using imported image as a template for map drawing, it can be usefull to make it brighter, darker or less
saturated to allow objects drawn on the top to be more visible and thus make the work more comfortable.

Use the main menu > Image > Background Filters window to adjust brightness or colors saturation. In this
case the Gamma parameter was adjusted to make image bighter.

Background image is much brighter, while all detail is still visible.
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Drawing of Objects
When drawing this island map, we will follow these steps:

1. Drawing of Areas (ocen, forest, land)
2. Drawing of Lines (land contours)
3. Drawing of Symbols
Some area types (Park) are always displayed beneath others, regardless on their creation order. Therefore, it is
necessarty to ensure that no other area covers them. This is the reason why we will make an opening in the
ocean object.
Areas should overlap each other a bit to avoid of displaying a small gap between the areas in GPS.

1. Areas
Let's draw the ocean area first. As the map is supposed to be rectangular in this case, the edges of ocean area
should lie exactly on the Work Area edges.
Select the Area tool and place the first node somewere near the bottom left corner of the Work Area. Set
the edge type to straight lines (control 1). Check the 'Snap to Work Area Edges' option (2).
Set the object pararmeters name (3) and type (4).
Draw the ocean object by clicking left mouse button on the Work Area. Select each of the nodes (5) and move
it towards the Work Area corner. As the 'Snap' option is ON, the nodes will be snapped to the corners
automatically.
Then click the right mouse button and choose the Finish Object command from the pop-up menu.

The ocean area now covers whole map. It is of an orange color, because this color was set in the Palette. Note
that new object is displayed in the Object Inspector window as a small icon.
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Now we will draw an opening for the ocean area to create a hole for the forest object to show through.
Select the Opening tool and draw the hole. After placing the first node, change the edge type to curves.
The future forest object should overlap the ocean and land objects (because forest is displayed beneath all
other objects), while the ocean object should overlap the land (because land will be on top of other areas). This
is the reason why the opening is draw on the edge of the forest (1) and why it ovelaps the land (2).
See below animated example on how to draw area or opening with curves.

Now there is the opening in the ocean object. Note that combined ocean+opening object is displayed in the
object inspector window. Separate parts are displayed in the Parts window to allow user to select and
manipulate them.
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To change color of the ocean object, press left mouse button on the color in the Palette and draw color to
object icon in the Object Inspector or to the selected object in the Work Area. Then release the button.
Another way is to click right mouse button on selected object and choose Color c ommand from the pop-up
menu to access the color dialog window.

Now we will draw the second area - forest. Select the Area tool and draw the forest object with use of curves.
Note that forest should overlap all other areas (ocean and land), because it is displayed beneath them. While
drawing the forest, set the area type to Park. Note the 3rd icon in the Park item which indicates that this
object is displayed beneath others.
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The forest area is finished. Now there are two objects in the Object Inspector window.

We will draw the 3rd type of area - land. Use the same approach as with the forest with a single difference the land area is on top of others and therefore you do not have to make overlays. There are 5 land areas in this
example.
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2. Lines
Now we will draw the lines (land contours).
Select the Line tool and draw all contours one-by-one with use of the curves. See below animated example
on how to draw line objects.

When lines are finished, select them all and click right mouse button on selection to access the pop-up menu.
Choose Properties to open Properties window and set Land Contour line type.
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The map looks like this now. Note that when you move cursor over the object icon in the Object Inspector
window, enlarged object icon and its description is displayed in the zoom window.

3. Symbols
Select the Map Feature tool and click on the respective spot on the map to place the symbol. Default type
of map feature is Summit, therefore only the object name should be changed, in the case. Select the object
and click right mouse button to access the pop-up menu. Choose Properties and set the object's name in the
Page 26 of 119

Properties window.

Now make the rest of symbols in the map. They are Map Features objects too. Select the Navaid>Racon type
in the Properties window after object is finished.
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Duplicate the Racon symbol and place it on the proper spot on the map. This simple example map is finished
now. To check how it will look like in the color or monochrome display GPS click on 'Color' or 'Grey Scale' tabs
in the bottom left corner of the Mapwel. You can switch between the tabs anytime during the map creation.
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Upload of Map into GPS
Use the main menu > File > Upload Map to GPS c ommand.
In case of problems with map uploading or displaying on GPS, please click here.
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How to load raster image into GPS
Use the main menu > Image > Automatic Vectorization c ommand.
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How to acquire GPS ID number
Use the main menu > GPS > Display GPS ID c ommand.
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Import of ESRI Shape Files
ESRI Shape Files are vector files that contain geographical data and optional attributes. Shape files can
support point, line and area features. Each layer is stored separately. An ESRI shape file consists of main file
(.SHP), an index file (.SHX) and attributes dBASE table (.DBF).
Use the main menu / File / Open or Merge function to import an ESRI shape file and convert it into the
Mapwel map. Then you can upload it into the GPS unit.
As the shape files are primarily not designed to use with GPS units and attributes of objects are specified by
user, Mapwel cannot assign the shape file attributes (data) to the map object properties like Name,
Comment, Type, etc. automatically. User is prompted to assign available shape file data to the map objects.

Because layers are stored in a separate shape files, it is necessary to Merge (with use of main
menu>File>Merge command) all shape files to create complete map in Mapwel. Mapwel stores whole map in a
single MPW file.

Loading of each SHP file involves three steps:
1. Selection of projection and datum used for representation of geographical data in SHP file.
2. Assignment of SHP attributes to types used by Mapwel.
3. Assignment of other SHP attributes representing name, comment, street name, phone number and other
data to Mapwel data structures.

Step 1 - Selection of projection and datum
Use the first tab in the SHP open file dialog to select coordinate system of the SHP file. You have to know
coordinate system of the SHP file. If chosen coordinate system is not the right one, map will be imported
improperly.
UTM Zone Number, UTM Latitude Band Letter and Planar Distance Units are controls for definition of
additional information for UTM system. UTM Latitude band letter affects only selection of the hemisphere
(northern or southern) when converting coordinates from UTM to Lat/Lon. Therefore, you can obtain the
same Lat/Lon coordinates for various band letters.
Use Data Size Reduction control to decrease the number of imported vertices (in case of area and line
objects). If imported data contain too many vertices, displaying of map on the GPS can be very slow. In such
a case, reduce the size of imported data to speed-up the map displaying. Reduction of vertices decreases
also precision of the map elements definition. The highest available accuracy of the map elements uploaded
into the Garmin GPS is approximatelly ±1.2 m. Accuracy of imported data should be lower or equal to this
value to optimize the speed of map displaying and data size.
Border is an empty space added around the map. Imported map may be clipped to bounding rectangle of all
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objects. Set Border to non-zero value if you need to add empty space around the map. Click left or right
mouse button on the value to increase/decrease it, or click on 'Border' label to set value by keyboard.
Click the Next>> button when you are finished with selection of coordinate system and data size reduction.

To learn about custom (user-defined) projections, click here please.

Step 2 - Assignment of attributes to Mapwel types
If any of the SHP file attributes defines the type of objects, you can use this tab to create attribute-toMapwel type conversion table.
Mapwel cannot recognize meaning of SHP attributes automatically, as they may contain any type of
information. Definition of conversion table allows user to assign proper type to imported objects.
You can skip this step if:
- there is no attribute that defines type of objects
- some attribute already contains Garmin object types
- you do not wish to assign type to objects.
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Follow these steps to create conversion table:
A) Select attribute that defines the object types.

B) Click on the first line of the first column in conversion table. Select attribute value from the pop-up menu
that appears.

C) Click on the second column in the same line. Select type of object from the pop-up menu. This type will be
assigned to all imported objects that have attribute ROADCLASS set to value Primary.
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D) Use Add button to create as many items in the table as neccessary. Define all attribute value - object
type pairs.

When finished, click on the Next>> button.

Step 3 - Assignment of other SHP attributes to
Mapwel data structures
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If there are attributes, which define the name, comment or other Mapwel-compatible data like street name or
phone number, use this tab to assign them to the respective Mapwel variables.
If imported file has an attribute that conforms the Garmin area, line and point indexing system, assign this
attribute to the Type variable. This condition is usually satisfied by shape files originally created for
GPSmapper software.
If type conversion table was defined in Step 2, Type is automatically set to the respective attribute.

Click the Finish button when the last step is finished.
In this case, imported map has four types of lines: 3 types as defined in the Step 2 and the 4th (default)
type for rest of the lines, which were left with the undefined type.
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Custom (User Defined) Projection
Mapwel supports hundreds of projections and datums. If you need to use custom projection, please use following
approach:

1. Open Userprj.INI file from your Mapwel>Settings folder in any text editor.
2. Edit parameters in either [USER_DEFINED_Transverse_Mercator] or

3.

[USER_DEFINED_Lambert_Conformal_Conic] section, according to the projection method. Then save
the edited file. Please note: change only fields at right side of '=', i.e. the key values. Do not change
section and key names.
When using below window for entering coordinates, check the Projection check box and select
X_User_Defined_Transverse_Mercator or X_User_Defined_Lambert_Conformal_Conic projection.

Current version of Mapwel supports transverse Mercator and Lambert conformal conic projections. Support
for other projections will be added in the future.

Custom projections are listed among pre-defined projections in this window,
which pops-up whenever coordinates are converted to WGS84.
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Map Coordinates
Following procedure is typically used to georeference imported raster image with Lat/Lon grid parallel to the
screen edges, which corner coordinates are known.
Click here for more image editing and calibration tools.
Map coordinates are displayed in a bar at the top part of the main Mapwel window. To enter a non-WGS84
coordinate, click left mouse button on arrow icon at left side of the box, instead of typing the coordinate into
the box.

Boxes for entering map coordinates.
A window for entering and conversion of coordinates in various coordinate systems will appear.
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Morphing of Image
This tool is intended for use with maps with unknown projection and datum, or with distorted maps. In other
cases, please try direct calibration first.
When drawing vector map with use of scanned paper map and tracks acquired with GPS, you can often
encounter the problem of paper map not matching the tracks, even if it was declared as a 'GPS map'. In such
case another problem pops-out and this is how to draw the rest of objects as it is not clear how to position
them with respect to the measured tracks. If whole image is just shifted, you can use main
menu / Image/ Move function to position the image under vector tracks properly. If deviation between image
and vector parts is not constant, correction requires more labour.

Fig. 1. Me asure d track s do not m atch scanne d pape r m ap ve ry we ll (le ft).
Im age afte r non-line ar calibration with thre e pairs of points (right).

Mapwel provides 'Image Morphing' tool for non-linear calibration of bitmap image to allow user to adjust image
before actually drawing vector objects on top of it. Morphing function uses pairs of points defined by user.
Image is calibrated so that area around the first point of each pair is transformed into area around the second
point of each pair.
Click on main menu / Image / Image Morphing to start image adjustment. The first pair of calibration
points will appear on the screen. They are one of top of the other. Click on the cross indicating position of the
point and move it aside. Now you can see both points in the pair and an arrow between them, which indicates
direction of image transformation in this place.

Fig. 2. Pair of calibration points.

If you click right mouse button on any of the calibration points, a pop-up menu appears, which contains
following c ommand: Preview, Original, Add Pair, Delete Pair, Morph Image, Cancel.
Page 41 of 119

Place calibration pair on some corresponding places (fig. 3. left) and use the Preview c ommand from pop-up
menu to see effect of calibration (fig. 3. right). First point of the pair is placed on street on the raster image.
Second point is placed on the corresponding place of the measured track. In Preview, area near first point is
transformed into area near second point and raster image matches the measured tracks much better.
We use Preview for now, because there will be more calibration pairs added. As adjustment is performed on a
raster image, each change could add distortion to the image. Therefore, use Preview to see effect of calibration
until all pairs are added. We will use Morph Image to perform all changes at once at the end of calibration.

Fig. 3. Im age with single pair of calibration points be fore calibration (le ft) and afte r calibration (right).

Now we will add second pair of calibration points to calibrate upper part of the image. Use Add Pair c ommand
from the pop-up menu. Notice that image returns to original form to allow user to place all points under the same
conditions. Use Preview command to see calibration with two pairs. You can switch between Original and
Preview mode to examine points placement and calibration effect.

Fig. 4. Im age with two pairs of calibration points be fore calibration (le ft) and afte r calibration (right).

Measured tracks fit adjusted image quite good now, except the bottom part of the image. There has to be one
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more calibration pair added.
Usually, there should be not many calibration pairs used, and they should be not placed one near to the other,
because influence of each pair reaches only to the nearest pair. If pairs are too near one to the other, image
gets distorted because of adjustments being too local.

Fig. 5. Im age with two pairs of calibration points be fore calibration (le ft) and afte r calibration (right).
Notice that roads ne ar 3rd pair are calibrate d e ve n whe n the pair
is not place d on any particular obje ct on the im age (le ft).
Use such approach to pre ve nt pairs be ing too ne ar one to the othe r.

The image seems to be calibrated quite well with three pairs of points. So far we were using the Preview mode.
Now click on Morph Image function to perform all adjustments to raster image at once.
When doing a large map, calibrate it part-by-part, each part with use of several pairs (like shown in above
example). Do not calibrate the whole map at once as each pair slows down the calibration process. As the
influence of pairs is more or less local, there is no reason to calibrate large map at once.
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Move Image
When drawing vector map with use of scanned paper map and tracks acquired with GPS, you can often
encounter the problem of paper map not matching the tracks, even if it was declared as a 'GPS map'. If the
whole image is just shifted, the main menu / Image/ Move function can be used to position the image under
the vector tracks properly. In other cases, please click here for more image editing and calibration tools.

Fig. 1. Im age unde r the ve ctor obje cts ne e ds to be shifte d.

Let's suppose that deviation is constant in this case. Click on main menu / Image/ Move command to start
image adjustment. Place pair of points to mark the current and desired position of any spot on the raster image.

Fig. 2. C urre nt and de sire d position of spot on raste r im age . The shift dire ction is m ark e d by an arrow.

Click right mouse button to access a pop-up menu. Select Move to shift the raster image.

Fig. 3. Im age shifte d to fit unde r the ve ctor obje cts.
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Exporting Maps
This function can be accessed via main menu > File > Export Map. Use this command to save map in format
other than Mapwel's native MPW format if you need to process data in other software. Mapwel currently
supports data export into Garmin IMG, Google Earth KML and cGPSmapper MP formats.
Mapwel Advanced licence is need to use export function. It is not available in Mapwel Basic.

Google Earth KML (Keyhole Markup Language) format
Maps exported into this format can be open in Google Earth and displayed on top of the earth surface. When
you create your own map, it is very useful to use this function to check accuracy of the map. If the 'terrain'
option in Google Earth is set, map is displayed so that it follows the terrain and it looks like 3D map.

Map e x porte d from Mapwe l in KML form at and loade d into Google Earth.
Map contains polygons, polyline s and sym bols.
PO Is are e x porte d with addre ss info (if supplie d).

Le ft: contour line s from Mapwe l displaye d 3D with 'Te rrain' option in Google Earth.
R ight: m ap from Mapwe l displaye d on top of the sate llite im age in Google Earth.

Garmin IMG format
IMG is native binary format of Garmin GPS units. These files can be loaded into GPS with our freeware
MapUpload (included with Mapwel installation files) or with 3rd party upload software.
Mapwel (both Basic and Advanced) allows to load maps directly into the GPS. If you prefer to use other
uploading method, please note that Garmin GPS units with files 'visible' from PC require all maps to be merged
into single IMG files with name GMAPSUPP.IMG. Find out more here.
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To define irregular shape of map, use the 'Background Area' polygon object in Mapwel. Please note that map can
contain only 1 object of this type and all other object must lie within its boundaries. If 'Backround Area' is used,
GPS does not display objects outside of this polygon.

IMG File Feature
Irre gular m ap shape
PO I addre sse s, C ountry and State info support
Use r de fine d zoom le ve ls
Use r de fine d polygons, polyline s and sym bols
Use r de fine d copyright te x t
Lock ing m aps with unlock code
Auto-routing
Marine m aps
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A vailability

How to erase all maps in GPS
Use the main menu > GPS > Erase Maps is GPS c ommand.
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How to compile multiple maps into
IMG format at once
Use the main menu > Files > Batch c ommand.
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How to erase specific maps
Use the main menu > GPS > Erase Specific Maps command to open window with list of maps to be erased.
The list is empty when window opens.
Click on Get Map List from GPS button to download list of maps from the GPS.
Click on Get Map List from IMG file button to load list of maps stored in the IMG file on PC. IMG file can contain
single map or map set with many maps. Users can build and edit their map set on PC and then load it to multiple
GPS units. Use this option to erase specific maps from your map set file on PC, without need to work with GPS.
Mark maps to be erased by clicking on the respective line of the Erase c olumn.
When finished, click on
button to perform erasure. All maps marked by X sign will be erased. This operation
may last even several minutes.
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How to change serial data transfer speed
Use the main menu > Edit > Preferences command or change the speed in the Map Transfer window.
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Guide Lines
Guide Lines are horizontal, vertical, or slanted lines that can be placed
anywhere in the work area window to aid in object placement and nodes
alignment.
To create a new guide line, position cursor on either vertical or horizontal
ruler, depress the left mouse button and drag cursor to the work area.
Guide lines can be used for areas and lines splitting. Place the guide line
on the object. Select object and then select the guide line. Click right
mouse button on the guide line to access pop-up menu. Choose Slice
Selected Objects c ommand.
Use main menu > Edit to lock or erase guide lines or to switch on/off
snapping of objects to the guide lines. Use main menu > Nodes to switch
on/off snapping of nodes to the guide lines.
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How to Create Map of Irregular Shape
If you want to draw your map so that it is not rectangular, in order to not cover surrounding countries, you
have to assign it an irregular shape.
To achieve irregular shape of the map when displayed in GPS, place a special area of Background Area type as
a first object in the map. This area is displayed in pink color in both 'Color' and 'Grey Scale' display modes.

Page 52 of 119

How to Measure Track Length
The total length of all selected line objects is displayed in Properties window on the Line Tab.

Page 53 of 119

How to define your own area, line
and symbol styles
Use the main menu > Objects > User Defined Styles command to launch the editor of above mentioned
styles.
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Main Window

1

The Tool Bar contains tools for creation, editing and transformation of objects. Click here to learn
more.

2

Work Area. When starting a new map, the work area is blank. User can import scanned image or
photo into the background of work area. Default colors of work area and grid lines are specified and
can be changed in Edit / Preferences.

3

Display Mode Tabs. In User mode, all objects (background image and map objects) are displayed in
user colors. In Image mode only the background image is displayed. In Vector mode only the map
objects are displayed (in user colors). Grey Scale mode simulates the monochrome display of GPS
units and Color mode simulates the color display of GPS units. Use the last two modes to see how
the map will look in GPS.

4

Button bar. The most used functions from main menu and pop-up menus are accessible through
these buttons.

5

Palette of Colors. Click right mouse button on any color to adjust this color. To change color of an
existing object, press left mouse button on color and drag and drop it on the object icon in Objects
Inspector window or on the selected object in the work area. To set color that will be used for
newly created objects click left mouse button on any color. Color that will be used for new objects is
outlined in black and white.
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6

Object Inspector window. All objects
created on working area are displayed
here in order of creation. It shows order
of objects, their type, visibility, name
and comment.
When composing complex map with
many objects, it is sometimes difficult to
isolate desired object in the work area.
Use Object Inspector in this case. To
change order of objects, select them
with right mouse button, drag them to
their new position, and release mouse
button. To Hide/Show object click the
eye icon to the left of each object.
To access menu to duplicate, delete, or
change properties, click right mouse
button on selected objects in Object
Inspector window.
To change color of object in Object
Inspector, press left mouse button on
any color in Palette and drag it to this
object. Then release the button.
Another way is to double click the
object icon to access the color dialog
box, or use the Color command from the
pop-up menu.
Color can be also dragged and dropped
from object in the list onto the palette.

To select non-contiguous subset of objects, depress the
Ctrl key and left click on each object.
In the editing mode the Object Inspector and Part
Inspector windows are replaced with basic parameters of
the object.
Read more about Object Inspector here.

7

Part Inspector window. Openings (holes) of area objects are displayed here as well as parts of
grouped objects. This window serves to select holes and parts for further manipulation, because they
cannot be selected in work area and in Objects Inspector.

8

Magnifying window. This window displays enlarged area around mouse cursor. It aids precise
placement of nodes, allowing user to maintain view of design in the Work Area. To hide this window,
use View/Zoom Window; this will enlarge the Parts Inspector window. When cursor moves over
Object Inspector, this window displays enlarged object icon and description.

9

Rulers. Press left button on vertical or horizontal ruler and drag mouse to Work Area to create a
Guide Line.

10

Status Bar. The mouse cursor coordinates, zoom and tool hint or other information are displayed
here.

11

Button for sending the map into the GPS unit. Same command is available in main menu / File.

12

Main Menu.

13

Find Object control. Type several characters of searched object name or comment into this box. If
object with name or comment that begins with these characters exists, Object Inspector scrolls the
list to make found object visible and selects it.

14

Zoom Levels Preview. Use this control to preview how map layers will be displayed in GPS at
various zoom levels.

A

Snap Nodes options. Use these check boxes to define snapping of nodes to work area edges, guide
lines or other nodes. Snapping helps precise placement of nodes. Same options can be found in main
menu / Nodes.
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B
C

Edge Mode combo box - choose line or curve edge as default when creating new objects.

Middle Point First check box - if checked, new curve element is created so that on first click,
line is created. On a second click line turns to a curve using the previous point (end of line) as middle
point of curve. If it is not checked, the curve is created on a first click, but the middle point must be
dragged to proper position.

D

Curvature of the rectangle with rounded corners.

E

Basic parameters of the newly created object. More parameters can be accessed with use of
Objects / Properties menu after finishing the object.
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File
The first 6 commands are New, Open, Open Recent, Save, Save As and Merge.
Open and Merge commands allow user to open map files in Mapwel MPW and other formats. Use Merge
command to combine two or more maps. Note that background bitmap is discarded when merging maps. Only
the vector map objects are preserved. Current version of Mapwel supports these formats:
File Format

Extension

Mapwel

.MPW

ESRI Shape File

.SHP

Google Earth
Keyhole Markup Language

.KML

GPS eXchange

.GPX

cGPSmapper
GPSMapEdit

.MP

MapDekode

.DBX

OziExplorer Waypoint File

.WPT

OziExplorer Track File

.PLT

Garmin GPS Database

.GDB

Garmin

.IMG

Read

Write

Comment

Files exprted in this format can be used
with Google Earth

Current v ersion of Mapwel does not
support auto routing, streets
numbering & marine charts

Mapwel A dv anced v ersion can export
maps into IMG format and/or upload
IMG files into GPS.

Click here to find out more about the ESRI shape files import. Mapwel also supports export into IMG map files
and their upload into GPS (see below), but it does not support editing of these files.
Upload Map to GPS converts the map data into proper GPS format and allows user to upload one or several
MPW and/or IMG map files into the GPS unit.
Upload IMG File to GPS launches the MapUpload.exe program, which allows user to upload one or several
IMG map files into the GPS unit. MapUpload does not perform any checking if IMG file is correct. This function
is intended to allow user to upload map files that he/she has created in other software. MapUpload also
allows user to wrap multiple IMG files into selfextracting .exe file. It is also possible to embed author's logo
and map set image, and optionaly lock maps to a specific GPS ID number. However, protection method
currently used in MapUload is not secure. Note: MapUpload.exe is a separate program that can be found in
the Mapwel folder. Unlike Mapwel itself, MapUpload is FREEWARE and it can be distributed separately. It
cannot be sold.
Countries and Cities. This command is used to define table of countries, states, cities, zip codes and
their mutual links. This table is necessary for creation of Cities and POI (points of interest) objects. For
detail information click here please.
Georeference Map. Use this function to establish relationship between the image coordinates (x,y) with
known real-world coordinates (longitude/latitude). Define location of two spots with known coordinates and
porgram will derive coordinates of the map edges. Mapwel uses coordinates of the map edges for all
calculations. Click here to learn more.
Export Map. Use this command to export map into Garmin IMG, Google Earth KML or cGPSmapper MP map
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file. This function works only in Advanced version of Mapwel. The GPS unit to which the registration is bound
must be connected and switched on.
Google > Launch Google Maps. Use this command to compare your map created in Mapwel with satellite
image or Google map. It is useful when it is not clear what kind of object the data you are working from
represent. This command opens separate web browser window and launches Google Maps web site with map,
satellite or hybrid image of the area of your map created in Mapwel.
Batch. Use this command to access window for batch conversion of multiple MPW, MP or DBX map files into
the Garmin IMG format. First, select files to convert into the Map Files Table. Then choose the destination
folder for the IMG files and hit Compile button. List of source files can be stored on disc with use of menu >
List > Save command for later re-use.
This function works only in Advanced version of Mapwel. The GPS unit to which the registration is bound must
be connected and switched on.
Merge IMG files. Use this command to merge several IMG maps into a single file. This command is useful if
you want to prepare maps for iQue, Nüvi, Zümo, or Colorado manually. Otherwise, Mapwel makes all map
operations (transfer, add map, erase, erase specific map) and user does not need to use this command.
The last command is Exit, which follows the usual Windows convention prompting user to name the map and
choose a location.
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GPS
Import Waypoints from GPS. Waypoints acquired by user can be used for map drawing. Import waypoints
from GPS and they become part of the map automatically. Please note that map (the "work area" in Mapwel)
is defined by North, West, South and East boundary (coordinate). User can either import only those
waypoints, which coordinates fit into the map boundaries, or map boundaries can be adjusted automatically
so that all waypoints fit on the map. Use the first option when you add waypoints to an existing map and you
want to ignore the waypoints that are outside of map. Use the second option when you work on a blank
background and you want to import all waypoints from the GPS.
Import Tracks from GPS. Tracks acquired by user can be used for map drawing as well as the waypoints.
Erase Maps in GPS. Use this function to delete all maps in the GPS. Base Map uploaded by manufacturer is
not erased.
Erase Specific Maps. Use this function to delete specific maps in the GPS or in the IMG file that contains
a map set (such file is usually named GMAPSUPP.IMG). Base Map uploaded by manufacturer to GPS is not
erased with this operation. Learn more about this function here.
Display GPS ID. Use this function to find out the unique identification number of the GPS unit defined by
manufacturer.
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Edit
Use the Preferences command to change the map and data transfer settings. The work area, nodes, edges,
grid and guide lines colors can also be changed under Preferences. Click here for more information.
Snap to Guide Lines snaps selected objects to nearest guide line when user moves objects in the
Transformation mode. Objects are snapped only if they are near to the guide line. This function allows user to
align objects with use of the guide lines. It works with whole objects (not just edited nodes as snap options
under then main menu > Nodes).
Lock Guide Lines disables editing of guide lines and adding of new guide lines. Locking of guide lines prevents
unwanted seizure of guide lines when working with digitized objects in the work area.
Erase Guide Lines deletes all guide lines in the work area.
Copy and Paste are clipboard operations.
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Image
Import command is used to bring an image into the background as a template for drawing; Mapwel can
import an image in JPG, GIF, BMP, PNG and TIFF formats.
Mapwel can import images up to 7700 x 7700 pixels if run on Windows XP or later, and 3000 x 3000 pixels on
previous versions of Windows. Larger images are scaled down to above size.
Import OziExplorer Calibrated Image command imports OziExplorer *.MAP with raster image and
georeferencing information. Current version of Mapwel supports only *.MAP files in WGS84 with 2 calibration
points. If 7 or more calibration points are used, Mapwel uses only 2 of them for georeference. *.MAP files
with 3-6 calibration points (affine calibration methods) are not supported.
Background Filters and Edit Image Window are described separately.
Rotate to Vertical and Rotate to Horizontal are tools for rotation of image. They are intended for precise
rotation of images that contain either vertical or horizontal lines (grid). Place rotation marks on the object
(line) in the image and then click right mouse button on the work area. Select 'Rotate Image' from the pop-up
menu. Image will be rotated so that marked line is vertical or horizontal, respectively. Please note: use Edit
Image Window for rotation of image with angle parameter.
Crop is tool for precise placement of crop marks and cropping of the image. Place crop marks on the image
and then click right mouse button on the 'scissors' symbol near the crop mark. Please note: Edit Image
Window can be used for cropping of image too.
Straighten. Use this tool to compensate distortion of scanned images or photos. If deformed image has
edges or grid that are supposed to be orthogonal, set the red marks on these deformed lines. Then click the
right mouse button on the work area and select 'Straighten Image' command from the pop-up menu. Image
will be transformed so that selected shape becomes a rectangle (see below image: blue shape transforms into
a black rectangle)

Image Morphing. Use this tool for non-linear calibration of raster image according to measured tracks and
waypoints. Image is calibrated with pairs of points that define source and destination areas of projection.
Move. Use this tool to move image under the vector map.
Calibration. Use his tool to calibrate image and the vector data drawn on top of the image.
Delete Image if you want to reduce the size of the MPW file (for publishing map on the Internet, for
example) and you do no longer need the background image.
Export as BMP saves your cropped and adjusted image as a separate bitmap file. Use this function if you
need to use the image in other application. Mapwel stores map, image and all other data in a single MPW file.
Automatical Vectorization. Use this tool for quick creation of GPS map from raster image.
Acquire (Scan) ... command launches the image scanning software. This command work with scanners that
support TWAIN. Scanned image is transferred into background of the work area as if it was loaded with
Import c ommand.
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Nodes
The Nodes Menu is accessible only in creation/editing mode.
Align Beginning to Previous Object moves the beginning of an edited object to the end of previous object.
The next command, Align End to Next Object, causes the end of the object being edited to the beginning of
the next object.
Align Line Beginning to beginning of Previous. When doing a complex line, some line parts start not on
end of previous part, but on its beginning, instead. Use this function to place beginning of the new part
exactly on beginning of previous part.
Reverse Nodes Order changes the order of nodes.
Use Delete Whole Edge command to erase whole edge and start its creation anew.
Snap nodes to Work Area Edges, Snap to Guide Lines, Snap to Nodes, Snap to Object Edges are
options for alignment of nodes during editing or creation of object. Nodes are snapped only if they are moved
near to the work area edges, guide lines, other nodes or edges of other objects, respectively.
Please note: these options affect snapping of the edited nodes. Snap options under the main menu > Edit
affect snapping of the whole objects.
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Shape
The Shape Menu is accessible only in the creation/editing mode. To use any of the 10 commands, place at
least one node in the work area, then select one of the shapes and draw it in the work area. Right mouse
click and select To Elements from the small pop-up menu. Mapwel will move the last node to the nearest
point on the shape just created and the shape will be started from that point. This means the shape can be
started from any point.
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Objects
Edit switches selected object to editing mode.
Group is function for combining several objects into one for easier manipulations. This lets you apply the
same transformations, properties and other changes to all the objects within the group at the same time.
Use

Ungroup function to divide grouped objects.

Sort Colors function changes order of selected objects so that objects of the same color are in the
successive order.
Sort Types changes order of selected objects so that Areas are listed first, Lines are next and then Points
of Interest, Exits, Cities and Map Features. This function helps you to organize objects in your map.
Sort Names function sorts selected objects alphabetically.
User Defined Styles command launches editor of filled areas, lines and symbols.
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Transform
Transformation Window command opens window for alignment of 2 or more selected objects. This command
may be useful when drawing reference frames (circles) around some object

Please note: use main menu > Convert > Create Circle around Point c ommand for easier and more
precise drawing of reference circles.
Combine Outlines makes single line object from series of lines.
Expand Objects enlarges selected objects by offsetting the object contours. It is intended for creation of
overlay of constant width between adjacent objects. Expand Objects command does not provide the same
result as normal enlargement.

Shrink Objects reduces size of selected objects by offsetting the object contours. Shrink Objects command
does not provide the same result as normal size reduction.
Shaping submenu contains commands for so called boolean operations on the filled areas. These operations
include union, intersection and difference. Click here for more information.
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Convert
The Convert commands work on objects selected with the Transform Tool (arrow) or in Objects Inspector.

Create Line from Area creates line object from selected area object. If area object has openings, program
will create also lines from openings as a separate objects.
Create Area from Opening creates a new area object from selected opening in an existing area. Opening
must be selected in the Parts Inspector window. This command is intended for situation when user needs to
create object of other color for a hole (opening) in the area. User should adjust the newly created area or
the opening to make them overlay each other, to avoid gaps when displayed in the GPS.
Create Area from Line creates a new area object from selected line object. If area is not closed, program
automatically closes it.
It is important to note that above commands will duplicate an object and then convert the new object as
selected. Below commands just convert selected objects without duplication.
Area to Opening command can be used to convert areas like land or islands to openings in the underlaying
area like ocean, for example. Map may display faster in GPS if island is made as an opening in the ocean area,
letting the background (yellow) area showing through, as opposite to island being a land area put on top of
the solid ocean area. In the first case, GPS has lower number of layers to display.
When converting selected areas to openings, some area object must precede selected objects in the list, as
newly created openings cannot be a stand alone objects and they must follow after the area object.
Map Feature to POI and POI to Map feature convert respective type of points into the other type.
Area to POI can be used to convert small areas like buildings into the points of interest.
Swap Object Name and Comment command helps to manipulate objects in the list when using the Sort
objects on Name function.
Create Circle around Point creates "circles" of defined radius around all selected points. Near poles very
large "circles" look deformed (see below image), because of coordinate system projection. However, realworld distance from center to any point on the "circle" is the same.
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Select
Commands in this menu allow to select vector objects with use of various criteria, or modify existing selection.
The first command is Zoom to Selected Objects. This command scrolls selected object(s) to center of the
screen and zooms in or out to fit selection to the screen. It helps to localize object(s) selected in the
Inspector window in the work area.
Next c ommand Zoom and Edit Selected Objects works in the same way as above command, but it also starts
nodes editing mode.
New Selection, Add to Selection and Select Subset options allow to define the way of how vector objects
are selected.
Rest of the commands in this menu allows to select multiple objects of the same type (like Roads, POIs with
address) at once. They work with either whole map or just selection, according to selection mode defined by
above options.
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View
Unlike the Eye icon in the Object Inspector window which hides/shows only particular objects, commands in
the View Menu hide/show all objects that fit user-specified criteria.
Areas, Lines, Points of Interest, Map Features, Cities, Exits settings show or hide respective type of objects.
Area Captions, Line Captions, Symbol Captions show or hide names (captions) of respective type of
objects in the work area. Symbols are all point objects (Points of Interest, Map Features, Cities, Exits).
Fill of Areas. Uncheck this setting to turn into the "wire frame" display mode. This is useful for example when you need to
make overlay of the Areas.
Show/Hide Objects. Use this sub-menu to show and hide set of selected or unselected objects.
Guide Lines, Button Bar, Grid, Rulers settings show or hide respective controls of the work area.
Zoom Window shows/hides zoom window in the bottom right corner of the screen. Hiding this window is
useful in case of low screen resolution (800x600, for example) to enlarge Object Inspector window.
GPS Display Frame. Check this setting to show frame of the GPS unit display in the 'gray scale' and 'color'
modes. This function allows you to see if map does not have too much detail and if it will be legible on the
GPS display. To change size of the display frame, click on the GPS icon in the upper-left corner with right
mouse button.

Nighttime, Marine Colors. Use these settings to change the map colors in 'gray scale' and 'color' display
mode. Marine colors works in both 'gray scale' and 'color' display mode. Nighttime has effect only in the 'color'
mode.

Start-up Window with Videos List. Uncheck this option if you do not want the list of tutorial videos to popup when starting the Mapwel.
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Object Inspector
The main features of Object Inspector are described in Main Window chapter.
Right click on selected object or objects in Object Inspector to access a pop-up menu for operations with
selected objects.
For meaning of Group and Ungroup commands please see Main Menu

/ Objects chapter.

To select and manipulate openings or grouped objects, use the Part Inspector window beneath the Object
Inspector window. It is not possible to select these parts directly on the Work Area.
To change order of objects in Object Inspector, select an object with a left click, depress the right mouse
button and drag it to its new position in the list. Then release the right button and, from the menu that appears,
choose whether the selection should be placed Before or After the item. You can choose also the Set
Identical Parameters command to copy properties from one object to another of the same type.
Double click on the object name to open the Properties window.

1

2

3

4
5
Zoom Nam e
Level & C om m e nt

List item in the Inspector window
1. Eye icon for showing/hiding object, 2. Small picture of object, 3. Type of
object, 4. Name and comment of object.
Object is visible. Left click on the icon to hide the object.
Object is invisible. Left click on the icon to show the object.
Object Icon.
Object is Area.
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Object is Area of type that is always displayed behind other objects.
Object is Line.
Object is land or depth contour (Line).
Object is railroad (Line).
Object is river (Line).
Object is trail (Line).
Object is Line of road type.
Object is Line of road type, with a road sign.
Object is Point of Interest (POI) with empty address fields.
Object is Point of Interest (POI) with address.
Object is City.
Object is Map Feature.
Object is Exit.
Object is Opening in the Area. Openings are displayed in the Parts window.
Object is composed of several other objects that are grouped.
Nam e
& C om m e nt

A6
4

Name and comment of object. Click on it to change object properties.
Automatic zoom level of object.
Individually set zoom level of object.
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Tools
From top to bottom:
-

Select and Transform Tool
Edit Edges Tool
Zoom Tool
Zoom 1 Tool
Pan Tool

-

Create
Create
Create
Create
Create
Create
Create

Area Tool
Opening Tool
Line Tool
Point of Interest (POI) Tool
City Tool
Map Feature Tool
Exit Tool

- Create Autorouting Highway *
- Create Autorouting Street *
- Create Autorouting Road *

- Create Marine Area **
- Create Marine Line **
- Create Marine Point **
- Create object with Freehand
- Trace tool (tool for vectorization of raster images)
* Tools available only in the Mapwel versions that support autorouting.
** Tools available only in the Mapwel versions that support marine charts.
Use zoom tool to zoom in (left mouse button click) or zoom out (right mouse button click). If you want to zoom
in a specific area, depress the left mouse button and drag mouse to make selection. Then release the mouse
button and selected area will be enlarged so that it fits on the screen.

Opening can be used only after Area or previous Opening object. It does not appear in Object Inspector
window as a separate object and cannot be selected directly on the Work Area. To select the Opening object
for transformation, use the Part Inspector window.
To add Opening to Area, the Area must be either selected or it must be the last object in the Object Inspector
list.

Page 73 of 119

Freehand Tool
Freehand tool works like a painting tool. Unlike the other Mapwel tools, which are based on the precise
manual placement of the nodes, curves and lines, Freehand tool allows to draw many of the Mapwel objects
with a free hand. Strokes are automatically converted to a chosen style. After conversion, strokes can be
edited as other vector objects (node by node). The Freehand tool can be combined with any other tools in
the Mapwel.
Like other creation tools in Mapwel, Freehand tool can be used with various display modes (User, Grayscale,
Color).
Freehand tool can work with any Microsoft Windows compatible mouse or digitizing tablet. Its use is not
restricted to any specific brand of tablet.
Before you start actual drawing with the Freehand tool, you should choose the style you want to use. Click
with right mouse button or corresponding tablet pen button depressed on the Freehand icon (in the Tool
Bar). Panel with freehand styles will appear (picture below). This panel can be invoked also by holding the
left mouse button or tablet pen tip depressed about 1 second on the Freehand icon.
Each style is represented by its icon. Hover the cursor over the icon to display the style name. Select desired
freehand style to activate the tool. Mapwel will switch to creation/editing mode.

Freehand Styles
1

Area

2

Opening of Area or Marine Area

3

Line/Road

4

Autorouting Highway *

5

Autorouting Street *

6

Autorouting Road *

7

Marine Area **

8

Marine Line **

* Styles available only in the Mapwel versions that support autorouting.
** Styles available only in the Mapwel versions that support marine charts.

Click left mouse button or tablet pen on the Freehand tool to start drawing. When the Freehand tool is active,
parameters of respective style are displayed on panel at the right side of the Mapwel window. After Stroke
options allow to configure the Freehand tool. For example, it is possible to define whether to finish freehand
mode after a single stroke or reactivate the tool.
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Freehand Options
Meaning of the After Stroke options is as follows:
- Finish Object - converts stroke into nodes and finishes creation/editing immediatelly
- Edit - converts stroke into nodes and switches to normal nodes editing mode
- Another stroke - converts stroke into nodes and allows to add another strokes.
When finished, single vector object contains several strokes.
Only one of above options can be active at once.
If Reactivate tool is checked, Mapwel automatically reactivates Freehand tool after
each stroke. This feature works only with Finish object option. To end strokes
creation, hit ESC or ENTER (RETURN) key on the keyboard, or click the STOP button
above the freehand options.
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Trace Tool
Trace Tool lets you create vector objects from raster images. This process is almost (though not entirely)
automatical. Trace tool allows to vectorize one object (or set of similar objects) at once, but it cannot
vectorize whole map with different types of objects at once. Tracing should be repeated for respective types
of objects (filled areas, roads, rivers, etc.). Trace tools works on images with any common color depth
(including True Color and bi-tone) that are sufficiently clean.
Raster image should be imported into work area with use of main menu>Image>Import c ommand.
Vectorization involves several steps (please see animated Fig.1):
1.
2.
3.
4.
5.

Activation of the trace tool, choosing of the proper trace style (see Fig.2).
Setting of magic wand tolerance, selection options and vector object properties.
Selection of respective object or multiple objects on raster image with magic wand.
Setting of vector objects parameters (type of line, zoom level, etc.)
Conversion of selected raster objects into vector objects.

Fig. 1. Animation - Use of the Trace Tool
Before you start using the Trace tool, you should choose the style you want to use. Click with right mouse
button on the Trace tool icon (in the Tool Bar). Panel with trace styles will appear (picture below). This
panel can be invoked also by holding the left mouse button depressed about 1 second on the Trace tool icon.
Each style is represented by its icon. Hover the cursor over the icon to display the style name. Select desired
style to activate the tool. Mapwel will switch to creation/editing mode.
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Fig. 2. Trace Tool styles (styles 3-7 are not available in the current version of Mapwel).

Tab. 1. Trace Styles
1

Area

3

Line/Road

4

Autorouting Highway *

5

Autorouting Street *

6

Autorouting Road *

7

Marine Area **

8

Marine Line **

* Styles available only in the Mapwel versions that support autorouting.
** Styles available only in the Mapwel versions that support marine charts.

Trace Controls
Use these controls to adjust:
- Parameters of vector objects
- Magic wand sensitivity (tolerance)
- Selection operations for selecting multiple objects

Color box - define color of vector objects. "Auto Color" must be unchecked.
Auto Color - color of vector objects will be taken from raster image.
Simplicity - varies in range 0..10.
0 means precise vector objects with high number of elements. 10 means low precision
and low number of elements.
Edge Type combol box - select curve (polycurve) or straight lines (polyline) type of
vector objects
Ignore Openings - valid only for filled areas. Holes in vectorized areas are ignored,
only the outer shape is vectorized.
Selection - various operations for selection of multiple or complex objects. Use "Add
Similar" if you want to select non-contiguous objects of similar color at once.
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User Defined Styles
Some Garmin GPS units support user defined styles* for filled areas, lines and points. Mapwel software includes editor
of these styles and library of predefined styles. Editor allows user to create her/his own fill patterns, colors, line
styles and point icons (cities, map features, points of interest and exits). New styles are saved with map in Mapwel
*.MPW format.
* Support of use r de fine d style s m a y re quire upgra de of the GPS firm ware . Use r de fine d style s we re succe ssfully te ste d on GPSm ap 60C ,
60C Sx , Nuvi a nd Vista C . If m a p with use r de fine d style s is loade d to Garm in GPS that doe s not support the m , obje cts are displaye d with
use of the GPS built-in style s, i.e . use r de fine d style s a re not use d.
Warning: if you cre a te m a p for loa ding into se ve ra l type s of GPS units, m ak e sure that all of the m support use r de fine d style s, be fore
actual cre ation of the m a p!
GPS units support single se t of use r de fine d style s for a ll m aps in the m e m ory. If m aps with diffe re nt se ts of style s are loade d into GPS
toge the r, only one se t of style s is a ctive , i.e . som e m a ps will be displaye d with wrong style s. Use menu>File>Save Whole Set and
menu>File>Open Whole Set com m a nds to copy a ll style s from one m ap to anothe r, to e nsure that the y use the sam e se t of style s.

Use r de fine d style s for fille d are a, line and point of inte re st.

It is also possible to save respective new styles as a separate files to disk, for future use in other maps, or to export
styles in *.txt format to use with other mapping software.

Library of pre de fine d style s.

Editor of user styles can be accessed with Mapwel main menu > Objects > User Defined Styles, or with pop-up
menu in the Properties window.
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Filled Areas
Editor of user styles contains separate tabs (1) for editing of areas, lines and points. User defined areas are bitmaps
of 32x32 pixels size. Only 2 colors (foreground and background) per pixel are allowed. User can define one pair of
colors for GPS daytime mode (13) and another pair for the nighttime mode (14). Use of the background colors is
optional. If they are not used, the area will be transparent.
It is possible to define name of the style (displayed by some GPS units) in up to 4 languages. Use table (15) to
type-in the name of the style. use right mouse button click on the Language column to choose from available
languages.
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Zoom level (16) control allows to define maximum zoom level at which the object using this style will be visible in
the GPS.
Layer specifies order in which object will drawn by the GPS. By assignment of proper layers user can define which
object will be drawn on top of the other objects.
Please see below table for description of the rest of the controls.
1

Tabs with editors for areas, lines and points.

2

Editor zoom control. It is also possible to use mouse wheel to zoom the work area
in and out.

3

Open and Save buttons. Use these buttons (or menu>File) to open or save styles
from/to library.

4

Pencil tool.

5

Paint Bucket tool.

6

Clear style button.

7

Scroll buttons.

8

Menu.

9

Work area.
Color palette. Some GPS units (GPSmap 60CSx, for example) use fixed 256-colors
palette. Use default colors from this palette to ensure that your styles will look the
Page 80 of 119

10

same on the PC and GPS. Use left and right mouse button click to copy color from
palette to Day colors controls. Use SHIFT, CTRL or ALT + left and right mouse
button click to copy color from palette to Night colors controls.

11

Style preview in daytime colors.

12

Style preview in nighttime colors.

13

Daytime foreground and background colors. If Background check box is
unchecked, the area will be transparent.

14

Nighttime foreground and background colors. If Background check box is
unchecked, the area will be transparent.

15

Table with optional style names in various languages.

16

Maximum zoom level for the style.

17

Combo box with available user defined styles.

18

Layer (see above). Use left and right mouse button click on the number to
increase/decrease the value. Click on the caption to use other ways of inserting
the value.

Lines
Lines editor is available on the second tab. Line styles are defined as either the bitmap of 32 pixels width and variable
height, or line with set pen and border width. In both cases, line uses only two colors, which can be defined
separately for the daytime and nighttime modes.
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Please see below table for description of the rest of the controls.
1

Pen and Border width for lines that are not defined by bitmap.

2

Use Bitmap control for switching on/off the bitmap mode. When displayed on the
GPS, bitmap is rendered with either horizontal or vertical sampling (according to
angle of the line), unless the Diagonal Sampling is enabled. In such case,
rendering uses also the diagonal sampling, but it does not look good for all bitmaps.

3

Height of the bitmap. Use left and right mouse button click on the number to
increase/decrease the value. Click on the icon to use other ways of inserting the
value.

Points
Unlike areas and lines that use only 2 color bitmaps, point styles use multicolored icons with optional transparent
background. Point icons are of variable size (up to 16x16 pixels), with up to 255 colors. Use left mouse button when
drawing the icon to fill pixels with color choosen from the palette. Use right mouse button to erase pixels
(transparent background). See next chapter (Menu) for useful command that help with drawing of the icons.
Please note: Left mouse click on the palette selects the drawing color. Right click opens the color mixer that allows
to define a new color. However, some GPS units (GPSmap 60CSx, for example) use fixed 256-colors palette and they
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are not capable of displaying more colors. In such case, all colors are mapped to the default palette.

Please see below table for description of the rest of the controls.
1

Preview of icon on various backgrounds.

2

Control to enable/disable nighttime icon.

3

Controls to switch beween editing of daytime and nighttime icon.

4

Width and Height of the bitmap. Use left and right mouse button click on the
number to increase/decrease the value. Click on the icon to use other ways of
inserting the value.

Menu
Menu > Edit contains some useful commands that make creation of the styles easier:
Derive Night Colors from the Day Colors command generates automaticall night colors for edited area or line style.
Replace Colors with Closest Matching Colors in the Palette command replaces all colors in edited style with the
most similar colors from the palette.
Add Border command creates thin border of selected color around the point icon (see above castle icon example).
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Copy Daytime Icon to Nigthttime Icon and Copy Nigthttime Icon to Daytime Icon commands create copy of
the respective icon.
Create Nighttime Icon from Daytime Icon command generates the nighttime icon, which is a darker copy of the
daytime icon.
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Edit Mode Pop-Up Menu
Click right mouse button in creation/edit mode on the work area to access this pop-up menu.

Finish Object ends the creation/edit mode. If object is Area, program automatically closes the object.
Close Edges closes the object. Use it for land and depth contour lines to ensure that line is closed.
Split Object. This command is available only for Line objects. Select square node (end of curve or straight
line element) and use this command to split the object.
Insert, Delete, to Curve and to Line commands are available only if rectangular node is selected (end of curve or straight
line element). Insert creates a new element before the selected element. Delete erases selected element. To Curve converts
selected straight line element into curve. To Line converts selected curve element to straight line.
Use Place Start Point Here command to change beginning of the object. Object (Area or Line) is
automatically closed and then the start point is re-positioned. This command is available only if rectangular
node is selected (end of curve or straight line element).
Mapwel automatically places the name label of Area object. If you want to assign position of label manually,
use the Place Name Label Here command. The label center is positioned on a place where the mouse
cursor was before you invoke this pop-up menu (small cross on the below picture). Note: Label position is
valid only in the Mapwel. It is not transferred into the GPS. GPS decides where to display name labels by
itself.
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Snap to Nearest Node moves selected node to nearest node which belongs to other object (not to
currently edited object).
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Shortcut Keys
3

Place beginning of object to end of previous object

e

Add new line part to edge

d

Add new curve part to edge

space

Finish object creation/editing, if possible

esc

Cancel object creation/editing

arrow keys

Scrolls Work Area

arrow keys
+ALT

Moves selected objects in transform mode and selected node in edit/create mode.

-

Zoom out

+

Zoom in

Page Up

Zoom out

Page Down

Zoom in

SHIFT+
Page Up

To Front (order of objects)

SHIFT+
Page Down

To Back (order of objects)

CTRL

When depressed, forces new lines and curves to precise horizontal, vertical or diagonal
direction in edit/create mode. If used with Shapes, creates precise circle instead of
ellipse and square instead of rectangle.

CTRL+1

Zoom to selected object(s)

CTRL+2

Zoom to selected object(s) and start nodes editing mode.

CTRL+A

Select all objects (in transformations mode)

CTRL+C

Copy selected objects into clipboard

CTRL+D

Duplicates selected objects

CTRL+E

Edit selected object. If more objects are selected, the first of them is edited.

CTRL+I

Import image

CTRL+N

Deselect (in transformations mode)

CTRL+S

Save file

CTRL+V

Paste objects from clipboard

CTRL+Y

Redo

CTRL+Z

Undo

Delete

Deletes selected objects (in transformations mode). Deletes an element that ends with
selected square (in edit/create mode).

INSERT

Inserts a new element before selected square node in edit/create mode.

CTRL+ALT+B

Background Filters (Image brightness and colors)
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CTRL+ALT+I

Display Edit Image window

ALT + mouse
cursor move

Pan work area without having to switch tools

ALT+A

Hide / Show Map Features objects

ALT+D

Hide / Show grid

ALT+E

Hide / Show Exit objects

ALT+F

Hide / Show Area objects

ALT+G

Hide / Show guide lines

ALT+I

Hide / Show City objects

ALT+O

Hide / Show Line objects

ALT+P

Hide / Show Points of Interest

ALT+R

Hide / Show rulers

ALT+T

Hide / Show button bar

ALT+Z

Hide / Show zoom window

Double click
on Work
Area

The new object is started immediately without need to select any tool. The new object
is of the same type as the last object.

CTRL+F1

Align beginning of object to end of previous object (in editing mode)

CTRL+F2

Align end of object to beginning of next object (in editing mode)

CTRL+F3

Align beginning of Line object to beginning of previous Line object (in editing mode)

CTRL+F5

* Set selected node(s) attribute "Intesection"

CTRL+F6

* Set selected node(s) attribute "Border node"

CTRL+F7

* Set selected node(s) attribute "No left turn"

CTRL+F8

* Set selected node(s) attribute "No right turn"

CTRL+F9

* Set selected node(s) attribute "No U turn"

CTRL+SHIFT+F5

* Clear selected node(s) attribute "Intesection"

CTRL+SHIFT+F6

* Clear selected node(s) attribute "Border node"

CTRL+SHIFT+F7

* Clear selected node(s) attribute "No left turn"

CTRL+SHIFT+F8

* Clear selected node(s) attribute "No right turn"

CTRL+SHIFT+F8

* Clear selected node(s) attribute "No U turn"

CTRL+SHIFT+F10

* Clear all restrictions of selected node(s)

CTRL+ALT+O

Create Line from Area

TAB

When creating new object, TAB key can be used to quick adjustment of the curve
elements. Create new curve element with TAB key instead of left mouse button. Then
move the mouse with TAB key depressed to adjust the curve. Then release the TAB
key.
Please note: to use the TAB key for curves adjustment, the edge mode must be set to
'curve'.
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x

Works like right mouse button. It is intended for use with tablet.

* applies to autoruting lines only.
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Built-in Tutorial Videos
To make the learning of map creation faster and easier, Mapwel includes technology for playback of built-in
tutorial videos. Mapwel installation file includes several tutorial videos with written comments made by
developers.
Videos are available from the list displayed in the start-up window. If you do not see this window at Mapwel
start-up, use the main menu / View to enable displaying of the start-up window.
Troubleshooting
Video playback may be affected or interrupted if you have tablet connected to your computer. Please
disconnect the tablet and try to play videos again.
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Background Image Filters
Background filters affect the way the background (imported image) is displayed behind the drawn vector
objects. Characteristics such as Brightness, Contrast, Gamma and colors Saturation can be adjusted, as
well as the grid color.

In contrast to graphics programs where the main meaning of filters is to enhance the look of an image, filters in
Mapwel are intended for dimming, darkening, brightening or other adjustment of image so that its colors do not
interfere with objects drawn on top of the background image. All these parameters are saved with map into a
single MPW file.
The grid color in this window does not affect the default grid color in Preferences that is used when starting a
new map.
Gamma parameter changes brightness mostly of dark colors and it does not affect absolute black and white.
All above settings do not affect the map appearance in the GPS. They serve to make map drawing more
comfortable.
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Preferences
The Preferences window is accessible through main menu under Edit / Preferences. The map and data transfer
settings as well as the work area and grid settings can be changed in this window. Choosing Save and Apply
means these parameters will be loaded automatically for each new map.

Edit Mode Colors allow user to define colors of edges and nodes used in edit mode.
If Max. Contrast is checked, edge and node colors are darkened or brightened according to the edited object
background. Max. Contrast can make edited objects more visible.
Note: the Grid Color can be set also in Image/Adjust individually for current design. It is saved with file and it
overrides the default grid color from Preferences.
Map Export parameters:
If map is Transparent, it is uploaded into the GPS without the background area and it overlays the GPS base
map or other maps located on the same position, letting the underneath maps show through. Use this setting if
you want to add details to an existing map in the GPS.
Please note: m any line obje cts are displaye d in a diffe re nt way if the m ap is transpare nt. Use the display mode Tabs to che ck the
look of your m ap afte r se tting it to transpare nt m ode . Mapwe l doe s not show unde rne ath m aps, be cause the y are in GPS, not in
Mapwe l.

Precision / Data Size. If map is drawn with use of curves, this control allows user to set to how many lines the
curves are converted when map is uploaded into GPS (as the GPS accepts only the lines). Mapwel provides
curves for easier drawing of map and for precision control. Once the map is drawn in curves, user can adjust
the size of data according to available memory in GPS.

Transfer Speed. Use this control to set speed of the map upload. If you encounter problems with loading maps
into GPS, decrease the transfer speed. This parameter affects only the serial data transfer. Speed of USB data
transfer is set automatically.
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Edit Image Window
Click here for more image editing and calibration tools.
The Edit Image Window is accessible through main menu under Image / Edit Image Window. While Edit Image
window is visible, four small rectangles appear in the work area to allow user to crop the image.

Rotate image first. Usually, the scanned image is not perfectly horizontal or vertical. Press left or right mouse
button on the red angle parameter or click the rotate icon to adjust the angle.
Second step is setting of crop lines. Press left mouse button on any of four small rectangles and drag them to a
new position. Area outside of selection will be cropped.
Please note: to rotate or crop image precisely, use main menu / Image / Rotate to Vertical, Rotate to
Horizontal and Crop tools.

After above steps, click Apply to perform changes.
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Countries and Cities Table
Access this table either via main menu > File or click Countries and Cities button in the Properties window.

Countries and Cities Table is used for City and POI (point of interest) objects. If you want to use City
objects in your map, you should fill this table first. City objects with undefined name are not transferred into
the GPS.
If you use POI objects in your map, you need to fill this table only if you want to use country, state, city or zip
code fields in the POI address. Any field in the POI address can be left empty.
To fill Countries and Cities Table follow these steps:

1. Enter countries and their codes (codes are optional) into the first table. To add new a line, press the F2
key on your keyboard. To delete last line in the table, hit F3 key on your keyboard.

2. If Country has states, enter states and their codes (codes are optional).
3. Assign respective country to each state. Click right mouse button on the 3rd column in the States table to
4.
5.
6.
7.

access pop-up menu with countries list.
Enter cities.
Assign respective country or state to cities. Click right mouse button on the 2nd column in the Cities table
to access pop-up menu with countries and states list. Countries are marked with a blue square and States
are marked with a red square.
Enter ZIP codes
Assign respective city to ZIP codes. Click right mouse button on the 2nd column in the ZIP Codes table to
access pop-up menu with cities list.

Main menu in this window contains following commands:
Table. Use it to save and open Countries and Cities Table. If several maps use the same table, you can save
the table and open it in another map. Import command allows to load countries, states, cities or zip codes from
separate text (*.TXT) files. TXT file must have following format:
Item1/Code1
Item2/Code2
Item3/Code3

Page 94 of 119

...
"/Code" section optional and it is valid only for countries and states (for example: Great Britain/GB). TXT files
with cities and zip codes should not have "/Code" section.

Edit. Use it to add or delete last line in the table.
Erase. Use it to erase tables in this window.
Sort. Use it to sort tables in this window alphabetically. If the are objects in the map which are already using
Countries and Cities table, they are automatically adjusted.

Valid characters
Country, State, City - letters and - & ' /
Country and State Code - letters
Zip Code - letters and digits
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Objects
Area Object
Use Area Tool
to create an area object. The edge of the area object is
composed of straight lines and curves. Small rectangles are end points of lines
and curves. Small circles are middle points of curves. The cross at the left side
is beginning of the edge.
Area object can contain openings. Opening objects must be created with
Opening Tool

and they must follow after the main Area object.

User can adjust properties of area object, like name, comment, zoom level and type.
Click with right mouse button on the object type to set individual zoom level for object
and/or edit user defined object style.
Areas are drawn in order determined by 'layer'. For example, 'Park' type objects are
drawn in layer 6, which means that they are draw behind areas in layers 1..5 and on top
of areas in layers 7 and 8. Therefore, some area types are displayed in the background,
even if they were created on top of other areas. To make such areas visible, you have
to create openings in objects that are displyed in front of them. 'Layer' is adjustable for
user defined styles.

The green object is the area that is displayed behind
others (park, in this example). We need to make an
opening in the surrounding land to make park visible (it
shows through the opening). Notice that the two areas
overlap. This is very important, because GPS could display
tiny gap between the two areas, otherwise.

Line Object
Use Line Tool
to create a line object. The edge of the line object is
composed of straight lines and curves. Small rectangles are end points of
straight lines and curves. Small circles are middle points of curves. The cross
at the left side is beginning of the edge.
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Depending on the type, Line object can have:




Normal name label with optional c omment.
Altitude or depth label.
Road label and any of the 6 road signs. Select the proper road sign in the Sign
combo box in Properties window.

Use the Line Tab in Properties window to measure length of line objects.

Symbols
These objects display on the map mostly as an icon with name. If cursor is placed on top of the icon (in
GPS or in 'Grey scale' and 'Color' tabs in Mapwel), the optional comment is displayed as a hint.
Point of Interest. This object can be assigned with address (house number, street, phone number, city,
zip code, state and country). If city, zip code, state and country are used, they must be choosen from
the already filled-in Countries and Cities table. Adrress is displayed in the GPS when you click on the
POI icon.
City. The city name must be choosen from the already filled-in Countries and Cities tabel. City cannot
have comment.
Map Feature.
Exit.
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Properties of Objects
To change parameters of several objects at once, select objects, click right mouse button and select
'Properties' command from the pop-up menu. Properties are organized in several tabs, according to type of
objects.

Color Tab
Area Tab
Line Tab
Map Feature Tab
City Tab
Point of Interest (POI) Tab
Exit Tab
Map Tab
Map Zoom Levels Tab
Map ID Tab

Color Tab
This tab is common for Areas and Lines. Symbols (Map Features,
Cities, POIs and Exits) do not have color property.
Use the color control to assign user color to the object. User
colors are used only in the Normal and Vector display mode.
When transferred to the GPS, the color information is discarded.
GPS uses its own colors according to type of object (see Area
and Line tabs).
User color can help you when you draw large and complicated
map. For example, you can assign different colors to land
contours according to their altitude.
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Area Tab
These parameters are applicable only to Area objects. All these
settings are uploaded with map into the GPS.
Control marked with arrow 1 is Individual Zoom Level of
selected object(s). If set to AUTO, the global zoom level of
respective area type is used (in this case, zoom level of 'Park'
type). Zoom Level defines maximum zoom in which the object is
displayed in GPS.
Name is the text that is displayed on the area in the GPS.
Comment is text that is displayed when you place cursor on
top of the area.
The list at the bottom contains available area types. Always
assign the proper type to the area object, because the area
type defines how the object is displayed in the GPS. Each row in
the list contains type name, color sample and gray scale sample
of the area.
Color sample shows the area color and pattern if loaded into GPS
with color display. Grey scale sample shows the area color and
pattern if loaded into GPS with monochrome display.
Arrow 2 marks Global Zoom Level of areas of 'Park' type. The
global zoom level is used for each object of the same type.
unless the object has set an individual zoom level.
To set global zoom level for any area type, click right mouse
button on the area type and use the pop-up menu that appears.
The icon marked with arrow 3 indicates layer in which the object
of respective type is displayed. By proper assignment of layers
to the types you can achieve one type of area objects to be
displayed on top of (or under) the other types.
Objects in layers with higher index are displayed behind areas
with lower layer index, regardless of their creation order (the
'Park', for example). To make such area visible, you have to
make openings to all areas that cover this area.

In this e x am ple , an ope ning was m ade to the ye llow are a to allow the gre e n
are a show through.
Line Tab with road Line obje ct
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Line Tab
These parameters are applicable only to Line objects. All these
settings are uploaded with map into the GPS.
When accessed through pop-up menu / Properties (i.e. not
through editing mode), the total length of all selected line
objects is displayed in this tab. You can use it to measure
imported tracks, for example. To change distance units use the
Edit > Preferences window.
Control marked with arrow 1 is Individual Zoom Level of
selected object(s). If set to AUTO, the global zoom level of
respective line type is used (in this case, zoom level of 'Road'
type). Zoom Level defines maximum zoom in which the object is
displayed in GPS.

Setting of this check box defines whether to display the
direction indicator after the line name or not.

Depending on the type, Line object can have:




Line Tab with norm al Line obje ct

Road label and any of the available 6 road signs (roads).
Normal name label with optional comment.
Altitude or depth label (land and depth contours).

Name is the text that is displayed next to the line or over the
line in the GPS. Comment is text that is displayed when you
place cursor on top of the line.
Altitude or Depth label can contain only digits. You can choose
the elevation and depth units in the Edit > Preferences
window.
Road label can contain both letters and digits.

Line Tab with e le vation (de pth) Line obje ct
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The list at the bottom contains available line types. Always
assign the proper type to the line object, because the line type
defines how the object is displayed in the GPS. Each row in the
list contains color icon and gray scale icon, line style and the
type name. Icons show the color (or several colors) used for
displaying of this line type in the color and monochrome GPS.
Arrow 2 marks Global Zoom Level of lines of 'Road' type. The
global zoom level is used for each object of the same type.
unless the object has set an individual zoom level.
To set global zoom level for any line type, click right mouse
button on the line type and use the pop-up menu that appears.

Map Feature Tab
These parameters are applicable only to Map Feature objects. All
these settings are uploaded with map into the GPS.
Meaning of controls marked by arrow 1 and 2 is the same as on
the area or line tab.
Map Feature Name is the text that is displayed next to the
object icon in the GPS.
Comment is text that is displayed when you place cursor on
top of the icon.
Coordinate controls allow you to change the object position.
To change position format, use the main menu Edit >
Preferences.
The list in the middle is the Map Feature Class. Some classes
have several subclasses that are displayed in the bottom list.
Choose the proper Map Feature type using the class and
subclass lists.
Icons in the class and subclass lists show how the Map Feature
will look like in the color GPS (left icon) and monochrome GPS
(right icon).
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City Tab
These parameters are applicable only to City objects. All these
settings are uploaded with map into the GPS.
City is the text that is displayed next to the object icon in the
GPS. User is not allowed to type the city name directly into this
box. It is necessary to fill the Countries and Cities table first
(click on the button at the bottom). Then it is possible to
choose city from drop-down list in this combo box.
Please note: City objects with undefined name are not
uploaded into the GPS.
Coordinate controls allow you to change the object position.
To change position format, use the main menu Edit >
Preferences.
Meaning of controls marked by arrow 1 and 2 is the same as on
the area or line tab.
The list in the middle is the City Type.
Icons in the type list show how the City will look like in the color
GPS (left icon) and monochrome GPS (right icon).

Point of Interest (POI) Tab
These parameters are applicable only to POI objects. All these
settings are uploaded with map into the GPS.
POI Name is the text that is displayed next to the object icon
in the GPS.
Comment is text that is displayed when you place cursor on
top of the icon.
Coordinate controls allow you to change the object position.
To change position format, use the main menu Edit >
Preferences.
Meaning of controls marked by arrow 1 and 2 is the same as on
the area or line tab.
The list in the middle is the POI Class. Some classes have
several subclasses that are displayed in the bottom list.
Choose the proper POI type using the class and subclass lists.
Icons in the class and subclass lists show how the POI will look
like in the color GPS (left icon) and monochrome GPS (right
icon). A few monochrome icons looks different in the Garmin®
Rino™ GPS. These icons are marked with *.
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POI can have addresses assigned. User can fill any of the
address boxes or left them empty.
House, Street and Phone data can be typed directly.
Country, State, City and ZIP Code are available from the
Countries and Cities Table, which must be filled first (click on
the button at the bottom).
Address is displayed in the GPS when you click on the POI icon.
The address format can be defined in the Map Tab (see below).

Valid characters
House - letters and digits.
Street - only letters.
Phone - digits and - sign.

Exit Tab
These parameters are applicable only to Exit objects. All these
settings are uploaded with map into the GPS.
Exit Name is the text that is displayed next to the object icon
in the GPS.
Comment is text that is displayed when you place cursor on
top of the icon.
Coordinate controls allow you to change the object position.
To change position format, use the main menu Edit >
Preferences.
Meaning of controls marked by arrow 1 and 2 is the same as on
the area or line tab.
The list in the middle is the Exit Class. Some classes have
several subclasses that are displayed in the bottom list.
Choose the proper Exit type using the class and subclass lists.
Icons in the class and subclass lists show how the Exit will look
like in the color GPS (left icon) and monochrome GPS (right
icon).
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Map Tab
These parameters apply for the whole map.
Map Name is the text displayed in GPS as a name of the map
Map Coordinates define the coordinates of bottom (south), top
(north), left (west) and right (east) edge of the map.
If you do not know the map edges coordinates, you can define
coordinates of two spots on the map and then let program to
calculate edged coordinates from them. See main menu > File
> Adjust Map Coordinates for more detail.
To change coordinates format, use the main menu Edit >
Preferences.
Address Format defines mutual position of house, street, city
and zip code data fields in the Points of Interest address (see
the POI Tab above) as it is displayed in the GPS.
Map Draw Priority affects order in which overlapping maps are
displayed on the GPS. Map with higher Draw Priority is drawn on
top of the overlapping map with lower Draw Priority, unless the
second map is transparent. Transparent maps are always
drawn on top of the non-transparent maps, even if they have
lower Draw Priority.
User Defined Styles check box allows to switch on/off saving
of the user defined styles into the map file when exporting map
into IMG file or uploading map to GPS. It does not affect the
storage of user styles in source *.MPW file.

Map Zoom Levels Tab
These settings apply for the whole map.
Map uploaded into GPS has several layers (zoom levels). Each
zoom level contains different amount of data to speed-up map
displaying and to prevent too many objects being displayed in
higher zoom.
Controls on this tab allow user to define number of zoom levels
and approximate zoom by which map layers appear on the GPS
display.
The number of objects visible in respective zoom level is
displayed at the right side of the check box.
In zoom level 0 all objects are visible. The higher is the zoom
level, the lower is the number of visible objects. Use controls in
above parameter tabs if you want to make some individual
object or all objects of the same type more visible or less visible.
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Map ID Tab
These settings apply for the whole map.
Each map contains ID number, which should be unique among
maps that are present in the single GPS unit at the same time.
Mapwel generates internal map ID automatically from map
coordinates and creation time.
This tab allows to define map ID manually and/or set the map ID
as a filename for export of map into the IMG and MP format,
which can be useful if you want to use map in other software
programs.
These settings are supposed to be used only by an expert user.
If you upload your maps directly into GPS with Mapwel or
MapUpload, you do not need to change default values.
Best Possible Accuracy informs you about accuracy available
for the current map scope (map coordinates range) when
uploaded map to the GPS.
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Transformation of Objects

Select object with use of Transform Tool

and:

To change size proportionally, left click any corner square and drag to desired size.
To change size non-proportionally, left click a middle square and drag to desired
size.

There are 2 ways of how to make selection of objects with marquee box:
1. Drag marquee box from left to right to select objects without completely enclosing them with a marquee box

2. Draw marquee box from right to left to select only those objects that lie completely within the marquee box.
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Shaping
These commands work on objects selected with the Transform Tool (arrow) or in Objects Inspector.
The main menu > Transform > Shaping commands allow to modify and combine selected objects with use of
the boolean operations.

Two se le cte d obje cts. Gre e n obje ct has an ope ning.

Union - this command creates an object or objects that contain all selected objects merged together. Vertices
inside of the filled areas are erased. If selected objects do not overlap one another, result of the union are
copies of the original objects.

Union of two obje cts.

Intersection - this command creates an object or several objects that are intersections of the selected
objects. If selected objects do not overlap one another, this function does not produce any new object (as
intersection does not exist).

Inte rse ction of two obje cts.

Difference - this command substracts selected objects from the object that is first in order of creation among
the selected objects. It is necessarry to arrange order of respective objects in the object inspector list before
use of this function, to assure proper order of objects. Newly created object or objects contain only those areas
of the first object that are not covered by the next objects.

Diffe re nce of two obje cts.

Page 107 of 119

Loading Raster Image into GPS
Automatic Vectorization
(Sample file in *.IMG format is stored in MAPWEL>FILES folder.)
This function can be accessed via main menu > Image > Automatic Vectorization. It allows to create map
for GPS from satellite images or scans automatically, within a few minutes. It is intended for use in situation
when there are no vector maps available of the area of interest, and drawing of precise vector map is not
efficient either because of lack of time or limited use of the map.
In fact, Garmin units do not allow to load raster image into GPS and use it as a map. This function automatically
vectorizes raster image and creates vector file compatible with GPS. Autovectorized maps contain thousands of
small color spots and are large is size and slow to render on GPS, therefore.

O bje cts autom atically ve ctorize d from raste r im age .
Map consists of large num be r of polygons.
C olors are de rive d from raste r and include d into "Use r de fine d style s"
for optional m anual tuning and/or transfe r to othe r m ap file .

Examples of autovectorized maps in GPS
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Pros: almost "one-click" process to create ready-to-use GPS map. You can create map like above examples in a
few minutes. Auto-vectorized map can be combined with waypoints, tracks, manually drawn objects or other
map data (like merged shapefiles, etc.)
Cons: GPS must support user defined styles (most of new units support them). Auto-vectorized map file is
larger than normal map file and its rendering in GPS is slower. Auto-vectorized map does not allow to search
objects. Objects do not have names, hints and other attributes. In other words, this kind of map is for viewing
only.

Technical notes
Auto-vectorized maps were successfully tested on Colorado, Nuvi, GPSMAP 60CSx, Street Pilot
c550.
Number of auto-vectorized maps can be loaded into GPS at once. Auto-vectorized maps can be
exported into IMG format and combined with any other GPS maps. However, they must use the same
set of user defined colors. To achieve this goal, use paletted images with same color palette.
Current version of Mapwel supports max. 86 colors for autovectorization.
Warning: you have to set map detail in GPS to 'Most' (default value is 'Normal') to see
autovectorized map in full detail. Otherwise, only a large colored squares are visible. Autovectorized
map is supposed to be rendered in full detail at zoom 800 m and closer.

Map se tup m e nu with De tail option.
This is scre e nshot from C olorado 300, but e ach Garm in GPS has som e m e nu for se tting this option.
Mak e sure to se t it to 'Most'.

How to use auto-vectorization
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1. Use any image editing software to resample and crop raster image. Reduce number of colors to fit into
2.
3.
4.
5.

range supported by Mapwel (up to 86). Save image into GIF, PNG or BMP format.
Import image into Mapwel. If number of colors exceeds max. allowed number, Mapwel automatically
reduces number of colors during autovectorization.
Georeference the map. You can skip this step if you import OziExplorer callibrated image.
Use main menu>Image>Automatic Vectorization function to create map.
Send map from Mapwel to GPS.

How to reduce number of colors in an image
To use image for automatic conversion into vectors, you may need to reduce number of colors. Mapwel reduces
number of colors automatically, but you may need to use the same color palette for several images. In such a
case, reduce colors manually, save the color palette and use it for other images too.
If you have Adobe Photoshop, you can use following approach:
1. Use Photoshop > main menu > Image > Mode > Indexed Color to open window for color reduction.

2. Select no dither, no transparency and set required number of colors Select any type of palette that works
best for your image.

3. Image with reduced number of colors lacks blue color for pool. We will add it manually. Undo the color
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reduction and repeat step 1. However, select 'Custom' palette in this case. Please note: in this simple example
number of colors is reduced to 9, but Mapwel supports much more colors.

4. Custom palette contains 9 color automatically selected in previous color reduction. Add light blue color as
10th color into palette and click OK. Image now contains 10 colors and light blue is among them. Save image
into BMP, GIF or PNG format to avoid colors distortion (do not use JPG format for the same reason).

Sample file in *.IMG format is stored in MAPWEL>FILES folder.
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Direct Map Calibration
Click here for more image editing and calibration tools.
This tool is available via main menu> Image > Calibration. It allows to transform raster image and vector data drawn
on top of the image to the Lat/Lon grid parallel to the screen edges. This method uses an affine linear transformation and will work
with maps which are rotated or skewed. The Lat/Lon grid of the image must be linear (straight lines) to allow linear transformation
to the grid parallel to screen edges. Even images with a non-linear Lat/Lon grid can be calibrated with this tool, if the grid nonlinearity is caused by projection (like UTM, for example). In such a case, map usually contains linear Easting/Northing grid and nonlinear Lat/Lon grid. Map should be calibrated with use of the Easting/Northing grid and Mapwel recalculates images so that the
Lat/Lon grid becomes linear.

Image with projection and grid lines
Below map is in UTM coordinates and has 2 grids: Lat/Lon grid (highlighted with blue color), which is curved
because of the projection, and Easting/Northing grid (highlited with red color), which is linear. Calibration and
conversion from UTM to Lat/Lon will make the Lat/Lon grid linear and parallel with the screen edges.

Le ft: non-line ar Lat/Lon grid. R ight: line ar UTM grid.

Use main menu> Image > Calibration to start the calibration tool. We will use 3 points with UTM coordinates
to calibrate the image. As the grid lines are drawn on the map, the easiest way is to position calibration points
on intersections of the grid lines

Le ft: im age with calibration points positione d on inte rse ctions of grid line s. R ight: de tail.

Panel at the right side of the Mapwel screen contains calibration controls. They should be used in the following
way:

1. Select any calibration point by clicking on the respective tab (1). Selected point is highlighted in the work
2.
3.

area and automatcially scrolled into center of the screen (if there is enough space to scroll). Number of
calibration points is defined in combo box above the tabs.
It is possible to use any of the snap node options to snap calibration points to nodes, objects, etc. It is
often convenient to snap calibration points to waypoints or guide lines placed on the map.
Define geographical position of each calibration point by clicking on the coordinates (3) and typing exact
coordinate values into boxes (6) in window that appears. Select projection (4), if any, and Datum (5). In
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this case, coordinates are defined as easting and northing, in meters. Click OK button (7) to close the
coordinates window.

Le ft: W indow for e nte ring point coordinate s in various syste m s. R ight: pane l with calibration controls.

When geographical position of all calibration points is defined, click Apply button at top of the Mapwel screen,
or use right mouse button click to invoke pop-up menu in the work area. Then select Apply command from the
pop-up menu. Image is calibrated so that Lat/Lon grid becomes linear (see blue grid on the below image) and
coordinates of the map are derived from the geographical position of the calibration points. Below map
coordinates are in WGS84.

C alibrate d im age .

O ve rall m ap coordinate s in W GS84, de rive d from the calibration points.

Notes:
When using 2 points calibration, the points can be placed anywhere on the map, but the best precision is
achieved when 2 points are as far one from the other as possible. Points cannot be placed on the vertical or
horizontal line, i.e. they cannot have any coordinate identical.
When using 3 points calibration, the points can be placed anywhere on the map, but the best precision is
achieved when 3 points are as far one from the other as possible. Points cannot be placed on the same straight
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line in any direction.
All calibration points must be specified the same coordinate system, i.e. do not change projection and/or datum
when entering next point.
If image does not contain grid lines, it is recommended to use some distinctive points like crossroads. Their
coordinates can be easily found with Google Earth, for example. Another way is to measure coordinates of these
points with GPS.
Map without projection is calibrated in the same way as above map, but "Projection" option should be disabled.
Coordinates are entered in Lat/Lon form.
When converting UTM coordinates to Lat/Lon, Latitude Band Letter affects only selection of the hemisphere
(north and south). Therefore, you may get the same Lat/Lon coordinates with different UTM Latitude Band
Letters.
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Setting Map Parameters
1. To define map position, either enter coordinates of the map edges into boxes in the button bar, or if you do
not know edge coordinates, use the main menu > File > Georeference Map to define map coordinates
according to two know spots on the map. Map must be already straightened and rotated so that north is up.

2. Place the two marks on the known spots on the map (grid intersections, for example) and define coordinates
of these spots. Then click the right mouse button to access the pop-up menu and choose Apply to Map
Coordinates. Mapwel recalculates the map edge coordinates according to defined two spots.

3. To change map name, address format or to see available map accuracy, select any object and click right
mouse button to access Properties window.
4. To change coordinates format, elevation units, distance units, map transparency, transfer speed and curves
precision, use the main menu Edit > Preferences.
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Conversion of Coordinates
Click here to learn about image calibration and map georeferencing methods.
Mapwel uses WGS84 for internal storage of all data, because internal format of GPS maps is based on the
WGS84 too. Setup menu in GPS allows to select from number of grids and datums, but displayed coordinates are
always calculated from data that are stored in default WGS84.
You can create map in Mapwel from resources in various coordinate systems. Mapwel allows to convert these
coordinates to GPS map native coordinate system WGS84.
When below window appears, select proper projection (if any) and datum and then type coordinates into the
boxes. Format of Lat/Lon coordinates can be set in the Position Format combo box. Click OK button to use
coordinates.
When using UTM projection, make sure to select proper planar distance units. Latitude band letter affects only
selection of the hemisphere (northern or southern) when converting coordinates from UTM to Lat/Lon.
Therefore, you can obtain the same Lat/Lon coordinates for various band letters.

To learn about custom (user-defined) projections, click here please.
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Manual map preparation for iQue,
Nüvi, Zümo and Colorado
All above units store detail maps on a memory card or in the internal memory. All detail maps, normally stored
as a separate img files, must be merged into a single file with GMAPSUPP.IMG name. Otherwise, GPS will not
recognize and display the maps.
Mapwel Advanced allows to generate separate img files and then merge them into a single GMAPSUPP.IMG file
for use with iQue, Nüvi, Zümo and Colorado .
Please follow these steps to create GMAPSUPP.IMG file:
Step 1. Generate separate img files with Mapwel Advanced. Use main menu > File > Export Map to save
each map with img extension.
Step 2. Use Mapwel main menu > File > Merge IMG Files to merge your img files into a single file and store
it with GMAPSUPP.IMG name. If you want to upload maps to iQue, proceed to step 3. If you want to upload
maps to other GPS, proceed to step 4.
Step 3 (iQue only). Use synchronization software included with your iQue (ActiveSync®, HotSync® or
other) to load finished GMAPSUPP.IMG file into GARMIN folder* of iQue memory card. Restart iQue to enable
uploaded maps.
Step 4 (Nüvi, Zümo, Colorado). Connect GPS to your PC and switch it on. Use Windows Explorer or any file
manager software to copy your GMAPSUPP.IMG file to GARMIN folder* in the GPS. Then disconnect the USB
cable and wait until GPS reads the maps.
*C he ck whe re your GPS store s de tail m aps (GMAPSUPP.IMG file ) and load your file into this dire ctory. The pre vious GMAPSUPP.IMG
file will be ove rwritte n. If you want to pre se rve m aps in this file , m e rge it to your m aps lik e any othe r im g file (se e ste p 2), prior to
loading your m aps to the card.

Step 2 is discussed in more detail bellow:

Step 2 - Creation of GMAPSUPP.IMG File
Use Mapwel Advanced main menu > File > Merge IMG File function to open window for merging separate
img files into a single file. Click right mouse button on the tab and use Add Map command from the pop-up
menu to add respective img files to the list.
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You can save list of img files on disc, for a future use. Use List > Save List command to store list into
Mapwel *.mml file.
When finished, click
button to generate single GMAPSUPP.IMG file from the list. Then upload this file to
the GPS as described in steps 3 and 4 above.
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Map Upload
User can upload one or several maps into the GPS unit. Mapwel uses unique GPS ID set by GPS manufacturer to
check the registration before the map upload. Therefore, user is prompted to attach the GPS that was used for
purchase of registration password.
If Mapwel is in Advanced version, user can disconnect the registration GPS and attach any compatible GPS for
map upload. Basic Mapwel version allows user to upload only to single GPS unit. Unregistered Mapwel allows
user to upload map to any compatible GPS, but map is truncated.

If you want to transfer several maps into the GPS at once, add maps to the map list. Use the main menu or popup menu (accessible with right mouse button click on the list) to manage the list items.
Geographic location of files transferred to GPS is plotted on the world map, for reference.
Current Map denotes map currently open in the Mapwel. Add to existing maps option allows to add your map
to maps already loaded in the GPS.
Important: if your GPS is connected to PC via serial port, please make certain that Serial Data Format in
Setup / Interfaces in the GPS is set to "GARMIN".
The map should only be uploaded to the unit for which it is intended. If this map is uploaded to a GPS unit other
than it is designed for, it will render the unit inoperative Do not operate the GPS unit during the transfer! Click
here to see list of supported GPS models.
In case of problems with map uploading or displaying on GPS, please click here.
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